Feedback message not work properly in a specific case (webblock / popup)

Consider the following case:

1. Have a webblock inside a screen

2. Add a link to a popup inside that webblock

3. create a button (eg. Save) in the Popup with a feedback message, a Popup_Editor_Notify and then a Popup_Editor_Close.

4. Add the OnNotify action related with the popup

When clicking Save, it should trigger a Feedback Message, call the OnNotify action and then close the popup.

In this case, the feedback message doesn't get triggered immediately. Only when we navigate to another screen/page the feedback message will appear (wrongly).


Anyone had this issue ?? or knows a workaround for it?


Luis

Hi Luis Soares,

Can not your FeedbackMessage be displayed on the popup call screen? Did you want to first display the FeedbackMessage and then the popup was closed?

Bernardo Condé wrote:

Hi Luis Soares,

Can not your FeedbackMessage be displayed on the popup call screen? Did you want to first display the FeedbackMessage and then the popup was closed?

Hello,

First i wanted the popup to close and then to present the message. In my opinion i think that should be the normal behavior.


Solution

Then, place the call of your FeedbackMessage, in the Notify of the popup that is in your call screen. Then, once you do Popup_Editor_Notify, and Popup_Editor_Close, it will call your Notify and it will be your Feedback. right?


Solution

yup, that's an option...

I hope I have helped, it will work ok for you.


Bernardo Condé wrote:

I hope I have helped, it will work ok for you.


Yes it helps. Thanks.

It will involve some code changing... I think it would be good if the platform would take care of this situation for us.


Yes, but the change is simple, so it's quiet. And if we stop to think, it makes sense, you notify, close, and soon after the message is displayed.

I hope to help.