Sending Email from O365 SMTP Server in Azure

Hi all, we got an authentication error by sending email. We use O365 in Azure, smtp.office365.com port:587. 

In the Dev Environment Service Center we have:

SMTP Server: smtp.office365.com

SMTP Port: 587

Username: <an currently user from O365>

Password: <password>

Then we got this error: "Error sending email 24021: 535 5.7.3 Authentication unsuccessful [AM5PR602CA0009.EURP189.PROD.OUTLOOK.COM]"

Screenshots are attached.

Have you an idea  what is the issue?

Thanks for any help.




Solution

Hi Carla,

That error message is coming from Office 365, not OutSystems. A quick google shows various articles that deal with this problem, but I can't assess which of these could help you, so please google yourself.

Solution

Hi Kilian, 

thank you


Kilian Hekhuis wrote:

Hi Carla,

That error message is coming from Office 365, not OutSystems. A quick google shows various articles that deal with this problem, but I can't assess which of these could help you, so please google yourself.



Hi Carla

How did you fix your email issue?

Would you like to share what did you do to fix it please?

Thanks.

Hi

I had the same error message today on my Personal Environment.

In my case this is probably because two factor authentication of my office 365 account.

I could resolve this problem by issuing an app password on my account page of office 365 and use it for SMTP password on OutSystems Service Center.

Junji Watanabe wrote:

Hi

I had the same error message today on my Personal Environment.

In my case this is probably because two factor authentication of my office 365 account.

I could resolve this problem by issuing an app password on my account page of office 365 and use it for SMTP password on OutSystems Service Center.

 

 Hello Junji, I have created a app pwd for my outlook ms office 365 and registered the same in service center "monitoring" tab section, but still same issue came for me!