I am trying to publish module but its gives error. The error is " File Save --It was not possible to save the module. " what should i do?

Does this happen in all modules?

Or only for this specific one?

Try saving it localy (without doing a 1-click-publish) to see if that works?

Hi Harish,

If I had to guess, you opened the module from a location that's read-only. When you open a file, instead of downloading from the server, Service Studio wants to save the changes to the module. If that's not possible because the module is read-only, or locked, you could get this error.

Hi Kilian Hekhuis.

Please explain point to point to fix this problem.

Hi Harish,

I gave you a possible source of the problem, did you check whether this is the case? Did you open that module directly from the file system or not? If so, is it on some network drive that could make it read-only or the like?

I have the same issue here. 

I have been working on my modules (2) from yesterday. When I tried to publish one of the Modules, got that error so, I tried to publish the other Module and the same message.

I really don't want to close the program and open it again because I have done that in the past and lost all progress made from last session.

Also, I am trying to 'save as' but nothing happens. Any advice on how not to lose all my progress from yesterday?


Thank you

Solution

Hi Christian,

"Save As" should word. You say "nothing happens" - is this before or after the file dialog appears?

Did you try the "Upload" feature (in the Module menu)? If that fails as well, you could try to copy/paste everything to a new eSpace, and save that (you can always merge it back if the issue is resolved).

Solution

Kilian Hekhuis wrote:

Hi Christian,

"Save As" should word. You say "nothing happens" - is this before or after the file dialog appears?

Did you try the "Upload" feature (in the Module menu)? If that fails as well, you could try to copy/paste everything to a new eSpace, and save that (you can always merge it back if the issue is resolved).

Hi Kilian,

For some reason 'Save As' is not working. When I select the folder to be saved in, the file simply doesn't exist. 


I did use the merge functionality and it works! Thank you