[Custom Input Masks] KeepMask Parameter in MaskPercentage not working

Forge Component
(38)
Published on 22 Apr by Marcelo Ferreira
38 votes
Published on 22 Apr by Marcelo Ferreira

Hi,

I changed KeepMask Parameter in Demo Module to True, expected result would be "Percentage value is: 10,33%" if I submit the form, but the suffix is lost -> "Percentage value is:10,33"

How can I solve this issue?

Thanks & regards

Magnus

Hi Magnus,

Looks like a bug on the component. Today I don't have time to look into it. But tomorrow I will try to give you a solution.

Regards,

Marcelo

Hi Marcelo,

do you have an update on this case? 


best regards

Markus

Magnus wrote:

Hi,

I changed KeepMask Parameter in Demo Module to True, expected result would be "Percentage value is: 10,33%" if I submit the form, but the suffix is lost -> "Percentage value is:10,33"

How can I solve this issue?

Thanks & regards

Magnus

Hi Maqnus,

I have updated some code of changes in component and demo application. Please find the attached files.

For demo reference :

https://vermaamit52.outsystemscloud.com/CustomMasksSample/Examples.aspx?_ts=637002555861944879

May be it can help :)

Thanks

AV



Processing Upload...

Amit Verma wrote:

Magnus wrote:

Hi,

I changed KeepMask Parameter in Demo Module to True, expected result would be "Percentage value is: 10,33%" if I submit the form, but the suffix is lost -> "Percentage value is:10,33"

How can I solve this issue?

Thanks & regards

Magnus

Hi Maqnus,

I have updated some code of changes in component and demo application. Please find the attached files.

For demo reference :

https://vermaamit52.outsystemscloud.com/CustomMasksSample/Examples.aspx?_ts=637002555861944879

May be it can help :)

Thanks

AV



+ Demo OML File