Error consuming SOAP OS 11

Hi,


I'm currently trying to use the follow SOAP service: https://ws.test.q.track.pt


The only thing i do is consuming the web service (all methods) and try to publish.. But i am always getting this error.. 

Invalid compiler output.
The WCF proxy code contains errors.


if i try to consume only 3 or 4 methods from the web service ( random one's) i get another error saying "object reference not set to an instance of an object" 


I already contacted the owners of the service and they said that none of the bellow cases(unsupported) are used 

image.png


If i try to cosume the SOAP web service with Soap UI or PostMan (for example) it works without any issue.. 



Jay Santos

Hi Romero,

The image link is broken, can you send it again?

In the meantime I'll check it out

Jay Santos wrote:

Hi Romero,

The image link is broken, can you send it again?

In the meantime I'll check it out

is this one ok ? 


Jay Santos

Much better, thanks. I'll check it out.

Jay Santos

Hi Romero,


It's a known issue already and support is working on it

https://www.outsystems.com/forums/discussion/47639/outsystems-11-soap-service/

Jay Santos wrote:

Hi Romero,


It's a known issue already and support is working on it

https://www.outsystems.com/forums/discussion/47639/outsystems-11-soap-service/

Thank you Jay for that input, glad they are already working on it  :) 


Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.