publishing errorThe following errors have occurred: • In Service Center on 2019-05-13

The following errors have occurred:• In Service Center on 2019-05-13 at 04:38:14 - The home module is not set for application 'todo'.


You need to set the Default entry point in your ToDo Project.

Right-click on HomeScreen of your Project & click on  Mark as Default Entry Point.

The default screen in mobile applications is defined in the Default Screen property of the module. Due to the mobile architecture, the accelerators for lists do not exist in the mobile runtime.

Hope it helps,


The above didn't work for me but found somewhere else that if you hover over your UI module on the develop tab that a number of new options "appear" in the grey bar and one of these is "set as home". Clicked this and then was able to publish OK.

I am also facing same issue. Setting the UI module as Home worked.

Tim Bates wrote:



Yet again I got the error and this time I couldn't see the link. Then found it has been changed to a small icon on the right hand side of the bar of your module on the Development Tab.