[XML Records] [XML Records] Declaration not added

Forge Component
(41)
Published on 27 May by João Melo
41 votes
Published on 27 May by João Melo

Hello,

I like the forge component XML Records a lot when I have to work on XML.

There are 2 things where I have to work around at the moment:

1)  I have the same issue mentioned in https://www.outsystems.com/forums/discussion/37074/declaration-missing-after-clearing-null-elements/ when I use RecordToXml. In RecordListToXml it is indeed solved.

2) When using RecordListToXml or RecordToXml boolean values are True or False (starting with a capital letter). According to the XML Schema specification, a boolean is true or false. True is not valid. Because of this my XML is not valid according to the system who is reading my file. 

Nice contribution, Twan. I've faced these issues a couple times also.

Hi Twan, João posted a new version that should fix both your issues. Let us know!

Thanks for the fast reply.

The second issue is solved. But the first issue unfortunately not yet.

You're right Twan, the first item is not fixed yet. I'll be publishing a new version in the next couple hours. Please wait for a new comment in this thread soon.

Solution

Hello, 

The 1.6.6 fixes this issue and is now available. Please feel free to give us any feedback.

Thank you.

Solution

Thanks again. Both issues are fixed now.