Hi there,


I'm having a problem when installing Platform Server 11. 

On Configuration Tool after granting permissions and Creating /Upgrading database on the Platform tab (and no problems here), using SQL Server and Windows Authentication, on the Log tab, doing the same procedure, the permissions are granted correctly, but when doing the "Create/Upgrade Database" the following error can be verified on Event Viewer:


"Error opening connection to the database: Login failed for user 'xxxxxxxxxxxxxx\xxxxxxxxxxxxxxx'.
Retrying...

   at System.Data.SqlClient.SqlInternalConnectionTds..ctor(DbConnectionPoolIdentity identity, SqlConnectionString connectionOptions, SqlCredential credential, Object providerInfo, String newPassword, SecureString newSecurePassword, Boolean redirectedUserInstance, SqlConnectionString userConnectionOptions, SessionData reconnectSessionData, DbConnectionPool pool, String accessToken, Boolean applyTransientFaultHandling, SqlAuthenticationProviderManager sqlAuthProviderManager)
   at System.Data.SqlClient.SqlConnectionFactory.CreateConnection(DbConnectionOptions options, DbConnectionPoolKey poolKey, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningConnection, DbConnectionOptions userOptions)
   at System.Data.ProviderBase.DbConnectionFactory.CreatePooledConnection(DbConnectionPool pool, DbConnection owningObject, DbConnectionOptions options, DbConnectionPoolKey poolKey, DbConnectionOptions userOptions)
   at System.Data.ProviderBase.DbConnectionPool.CreateObject(DbConnection owningObject, DbConnectionOptions userOptions, DbConnectionInternal oldConnection)
   at System.Data.ProviderBase.DbConnectionPool.UserCreateRequest(DbConnection owningObject, DbConnectionOptions userOptions, DbConnectionInternal oldConnection)
   at System.Data.ProviderBase.DbConnectionPool.TryGetConnection(DbConnection owningObject, UInt32 waitForMultipleObjectsTimeout, Boolean allowCreate, Boolean onlyOneCheckConnection, DbConnectionOptions userOptions, DbConnectionInternal& connection)
   at System.Data.ProviderBase.DbConnectionPool.TryGetConnection(DbConnection owningObject, TaskCompletionSource`1 retry, DbConnectionOptions userOptions, DbConnectionInternal& connection)
   at System.Data.ProviderBase.DbConnectionFactory.TryGetConnection(DbConnection owningConnection, TaskCompletionSource`1 retry, DbConnectionOptions userOptions, DbConnectionInternal oldConnection, DbConnectionInternal& connection)
   at System.Data.ProviderBase.DbConnectionInternal.TryOpenConnectionInternal(DbConnection outerConnection, DbConnectionFactory connectionFactory, TaskCompletionSource`1 retry, DbConnectionOptions userOptions)
   at System.Data.SqlClient.SqlConnection.TryOpenInner(TaskCompletionSource`1 retry)
   at System.Data.SqlClient.SqlConnection.TryOpen(TaskCompletionSource`1 retry)
   at System.Data.SqlClient.SqlConnection.Open()
   at OutSystems.HubEdition.Extensibility.Data.TransactionService.BaseTransactionService.GetConnection()
   at OutSystems.HubEdition.Extensibility.Data.TransactionService.BaseTransactionService.CreateConnection(Int32 numRetries)
   at OutSystems.HubEdition.Extensibility.Data.TransactionService.BaseTransactionService.CreateConnection(Int32 numRetries)
   at OutSystems.HubEdition.DatabaseProvider.SqlServer.ExecutionService.ExecutionService.GetServerProperty(String propertyname)
   at OutSystems.HubEdition.DatabaseProvider.SqlServer.ExecutionService.ExecutionService.GetServerEngineEditionProperty()
   at OutSystems.HubEdition.DatabaseProvider.SqlServer.ExecutionService.ExecutionService.get_ServerEngineEdition()
   at OutSystems.HubEdition.DatabaseProvider.SqlServer.Platform.Configuration.ConfigurationManagerUtils.GetSqlEngineEdition(IRuntimeDatabaseConfiguration config)
   at OutSystems.HubEdition.DatabaseProvider.SqlServer.Platform.Configuration.TwoUserDatabaseConfigurationManager..ctor(ISettableTwoUserDatabaseConfiguration uiConfiguration, IPlatformDatabaseConfiguration systemDatabaseconfig)
   at OutSystems.HubEdition.DatabaseProvider.SqlServer.Platform.PlatformDatabaseProvider.GetLoggingConfigurationManager(ISettableTwoUserDatabaseConfiguration uiConfiguration, IPlatformDatabaseConfiguration systemDatabaseConfig)
   at OutSystems.HubEdition.ConfigurationTool.ConfigurationToolDatabaseAccess.GetLoggingDatabaseConfigurationManager(EnvironmentConfiguration config)
   at OutSystems.HubEdition.ConfigurationTool.ConfigurationFrmCode.#gbc()
   at OutSystems.HubEdition.ConfigurationTool.UILoggingDatabaseConfiguration.#Zcc(Object s, EventArgs e)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
   at System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG& msg)
   at System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG& msg)
   at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
   at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
   at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
   at OutSystems.HubEdition.ConfigurationTool.ConfigurationFrmCode.#4Kb(String adminUserPassword)
   at OutSystems.HubEdition.ConfigurationTool.ConfigurationTool.SharedMain(Args arguments, Exiter exiter)
   at OutSystems.HubEdition.ConfigurationTool.ConfigurationTool.#uTb(String[] args)
"


Has anyone suffered from this error and  how to get through it?


Hi, are you able to connect to that DB server through another client tool?

Good morning,


Yes, I already tested and I can connect to that database with another client, using Windows Authentication.


What seem weirder to me, is that when I granted permissions, the users were added to the DB, and the permission were correctly granted. But then, I can't connect to the DB.

I recommend you to raise a support ticket then and have OS team looking at this.

Please, consider sharing the results here afterwards.

Try to look into the ConfigurationTool.log file. It hold more information and it might show why it goes wrong during the create/upgrade action.

you can find it in c:\windows\temp