[Location Plugin] Unable to get Location | Error Code 0 | Lat & Long Empty | Success Flag False

Forge Component
(21)
Published on 3 Apr by OutSystems R&D
21 votes
Published on 3 Apr by OutSystems R&D

Hi,

I am using this plugin & it was working perfect but right from now it started giving an error.

The Plugin is not able to fetch Location on Android-8,9

Response:

Error-Code : 0
Latitude : ""

Longitude : ""


I tried multiple times from 2  other locations, even on an Open Ground :)

Please help

Hi assif_tiger,

I'm assuming you have at lest one of Wi-Fi, Mobile Data and/or GPS enabled on your Android device, correct?

I was checking... according to this, it could also be a Plugin issue?... what did you change from when it was working to now? and does it never work now, or just sometimes?

Hello Jorge Martins,

Thanks for the Reply.


I changed nothing,

perhaps to clear you on use cases.

I try on:

1- A device with Mobile-Internet & GPS Enabled

2- A device with Mobile-Internet & GPS Disabled

3- A device with Wifi-Internet & GPS Enabled

4- A device with Wifi-Internet & GPS Disabled


Yep sometimes I observer this issue used to come, but it was not continuous.
Today I am hitting my head for the last 3 hours to get the location but failed.

I also tested the same on Android-6 & Android-7, it was working before but not today.

I tried right on 3 locations 3 different countries.


Tried with this too, but did'nt help:

https://github.com/apache/cordova-plugin-geolocation/issues/120

"add { enableHighAccuracy: true }"

Have you tried this on iOS? does it work? Have you debugged the application running on the device (check this on how to debug a native application)

Do you think it could be related to this? The Cordova geolocation plugin will silently fail if the GeoLocation service is disabled and there's no error callback (haven't checked the Location Plugin implementation if that could be the case).

- I didn't test it yet on iOS.

- maybe I can debug with Android-Debugger & come with some log's or search on Service Center.

- Permission is given & I too confirmed it from App Settings



You can debug an application running on your device using Service Studio directly. Follow the link I provided above for details. 

Hi Jorge Matins,

Strange but the plugin working smoothly in a sample app on the same espace with the same plugin.