[OutSystems UI Web] Menu does not work on iPad / Logout

Forge Component
(39)
Published on 2 Oct (2 weeks ago) by OutSystems R&D
39 votes
Published on 2 Oct (2 weeks ago) by OutSystems R&D

The menu (activated by the hamburger button) on certain iPads does not work. The screen greys out but the menu does not become visible. Experienced this on iPad 2 on Chrome and Safari browsers. I believe I have seen it working correctly on newer/larger iPad models.

On iPhone (experienced on iPhone X model), the menu works as expected. However, on the iPhone the LoginInfo (in the 'Right' placeholder) in the menu bar of the layout, is not visible. The important function therefore not available is to log-out.


Hi, Hubert,

You can create a button with the log-out function, to appear only when it is a mobile device in use.

Eduardo Rodrigues wrote:

Hi, Hubert,

You can create a button with the log-out function, to appear only when it is a mobile device in use.

Yes, I know that, but I am asking about apparent issues with OutsystemsUI Web.


Hubert wrote:

Eduardo Rodrigues wrote:

Hi, Hubert,

You can create a button with the log-out function, to appear only when it is a mobile device in use.

Yes, I know that, but I am asking about apparent issues with OutsystemsUI Web.


I went through this same problem. What happens is that the logout function is not on the web block menu. So I added one more item to the menu, the logout function, but that was only visible on mobile devices.


Thanks for the workaround idea. I think it is a omission of the theme though.