[Embedded Scanner Plugin] Error: Cannot find module 'xcode'

Forge Component
(1)
Published on 18 Jan by Miguel 'Kelter' Antunes
1 vote
Published on 18 Jan by Miguel 'Kelter' Antunes

I'm getting the following when trying to use this plugin and build the iOS app in OS11. Any idea?


Calling plugman.fetch on plugin "https://github.com/kelter-antunes/cordova-plugin-qrscanner-extended.git"

Fetching plugin "https://github.com/kelter-antunes/cordova-plugin-qrscanner-extended.git" via git clone

Running command: git clone --depth=1 https://github.com/kelter-antunes/cordova-plugin-qrscanner-extended.git /var/folders/vm/t_bkg0md7bl592_7jh9jb1h40000gq/T/git/1560613717519

Command finished with error code 0: git clone,--depth=1,https://github.com/kelter-antunes/cordova-plugin-qrscanner-extended.git,/var/folders/vm/t_bkg0md7bl592_7jh9jb1h40000gq/T/git/1560613717519

Repository "https://github.com/kelter-antunes/cordova-plugin-qrscanner-extended.git" checked out to git ref "master".

/tmp/build/source/plugins/cordova-plugin-qrscanner"...

Plugin "cordova-plugin-qrscanner" fetched.

Calling plugman.install on plugin "/Users/mabs01/NativeBuilder/builds/e76bb967-af6d-4044-90e0-95192fe09d60/source/plugins/cordova-plugin-qrscanner" for platform "ios

Installing "cordova-plugin-qrscanner" for ios

Running command: /Users/mabs01/NativeBuilder/builds/e76bb967-af6d-4044-90e0-95192fe09d60/source/platforms/ios/cordova/version

Command finished with error code 0: /Users/mabs01/NativeBuilder/builds/e76bb967-af6d-4044-90e0-95192fe09d60/source/platforms/ios/cordova/version

Dependencies detected, iterating through them...

Requesting plugin "cordova-plugin-add-swift-support".

Plugin dependency "cordova-plugin-add-swift-support" not fetched, retrieving then installing.

Fetching plugin "cordova-plugin-add-swift-support" via npm

Copying plugin "/Users/mabs01/.cordova/lib/npm_cache/cordova-plugin-add-swift-support/2.0.2/package" => "/Users/mabs01/NativeBuilder/builds/e76bb967-af6d-4044-90e0-95192fe09d60/source/plugins/cordova-plugin-add-swift-support"

Installing "cordova-plugin-add-swift-support" for ios

Finding scripts for "before_plugin_install" hook from plugin cordova-plugin-add-swift-support on ios platform only.

No scripts found for hook "before_plugin_install".

Install start for "cordova-plugin-add-swift-support" on ios.

PlatformApi successfully found for platform ios

Beginning processing of action stack for ios project...

Action stack processing complete.

Install complete for cordova-plugin-add-swift-support on ios.

Finding scripts for "after_plugin_install" hook from plugin cordova-plugin-add-swift-support on ios platform only.

No scripts found for hook "after_plugin_install".

Finding scripts for "before_plugin_install" hook from plugin cordova-plugin-qrscanner on ios platform only.

No scripts found for hook "before_plugin_install".

Install start for "cordova-plugin-qrscanner" on ios.

Beginning processing of action stack for ios project...

Action stack processing complete.

Install complete for cordova-plugin-qrscanner on ios.

Finding scripts for "after_plugin_install" hook from plugin cordova-plugin-qrscanner on ios platform only.

No scripts found for hook "after_plugin_install".

Adding cordova-plugin-qrscanner to package.json

Saved plugin info for "cordova-plugin-qrscanner" to config.xml

Executing script found in plugin cordova-plugin-add-swift-support for hook "after_plugin_add": plugins/cordova-plugin-add-swift-support/src/add-swift-support.js

Error: Cannot find module 'xcode'