[Html2PdfConverter] HtmlToPdfConverter: The device is not ready

Forge Component
(63)
Published on 17 May by Guilherme Pereira
63 votes
Published on 17 May by Guilherme Pereira

Hi all,

I have tried to upload the file wkhtmltopdf.exe on administration.aspx page, but it returns the message "The device is not ready". 

The wkhtmmltopdf.exe is downloaded on https://wkhtmltopdf.org/downloads.html, I have downloaded abd uploaded several series including MSVC 2015, MXE and MinGW-w64, but all return same result.

Could anyone please advise? Thanks.

Hi David,


Is your environment in the cloud or on prem? Is it a personal or enterprise installation?


What is the specific file you’re trying to upload that is causing the error?


Can you share the detailed error log from service center?


Thanks,

Guilherme

Hi Guilherme,


I tried to upload the file in my on-premises environment, The file I uploaded for PDF Generator is wkhtmltopdf.exe

I also tried to download and upload the binaries from Stable and Bleeding Edge series for Windows 64 platform, but all return same error.


Here you are. Thanks for your help!


BR,

David

Hi David,


From your configuration the only thing that occurs to me is to check the path to the binaries directory and that the folder actually exists on the server and the IIS user has permission to write to it. If that fails you can try and write on the running dir itself which may or not work depending in the permission your server has defined.

But because the error is occurring when writing the file to the disk it could be something to indicate some kind of hardware problem with the HDD of your server so, as you’re on prem, you should check with your sysadmin what’s happening at the server level.

If the above suggestions don’t work you could try and build a simple app that uploads a file to the same dir or other dirs. Does it work or do you have the same error?


Thanks,

Guilherme