Unable to get role_show.aspx page in users website

Hi,

When I try to click on user role in users page(https://environmentName/users) I am getting following error

Previously it is used to work fine displaying the users mapped to that role.Now i am getting the Internal Error.Recently we have upgraded the platform from 11.0.108.0 to 11.0.424.0 .Is this reason to get this error.Is there anything to configure to avoid this error?

Thanks,

Pavani

Hi Pavani,

What kind of error is showing up in Service Center?

Have you also published system components solution during the Platform upgrade in order to get the upgraded versions of the system modules?

In any case, further information is needed in order to help you out.

Regards,

Nordin

Hi Nordin,

I am getting the following error in service center

Error executing query. Error in advanced query GetUsersByRoleId in Preparation in Role_Users in Applications in Users 

Reference to database and/or server name in 'DB.DBO.OSSYS_USER_T20.ID' is not supported in this version of SQL Server.

And also status for system components is giving below warning

Some Modules have pending configuration changes. Apply them using a solution containing all Modules.


Please suggest

BR

Pavani

Hi Pavani,

You should do as suggested and create and publish a solution containing all modules.

Last part of a Platform upgrade is to republish all modules in order to update them.

Try and see whether this fixes the issue.

Regards,

Nordin

Hi Nordin,

I have published the solution containing all modules.

But still I can see the same issue in users page.

what does this error meant exactly(Reference to database and/or server name in 'DB.DBO.OSSYS_USER_T20.ID' is not supported in this version of SQL Server.)

Thanks,

Pavani

Hi Pavani,

Did the warning of system components disappear?

I would open a support case with Outsystems for this matter. I would say something went wrong during the Platform upgrade.

Regards,

Nordin


Hi Nordin,

Those warning disappeared once publish is done.

BR

Pavani.

Hi Pavani,

One other thing comes to mind.

Did you make sure to upload and publish system components from the installation folder during the Platform upgrade?

It's located here: C:\Program Files\OutSystems\Platform Server\System_Components.osp

You can check whether the current published version of system components is 11.0.108.0 or 11.0.424.0.

For further info see: https://success.outsystems.com/Support/Enterprise_Customers/Installation/Install_System_Components

Regards,

Nordin

Hi Nordin,

I raised the support case, they resolved the issue. There is a problem in users espace.

One doubt can we modify the user espace. When I tried to open the user espace i would get the following popup  and I have selected the open a clone option. What exactly clone meant?

Thanks,

Pavani

Hi Pavani,

Great to hear they've resolved the issue!

The Users eSpace is indeed a system module. This means you cannot modify it (only Outsystems can).

You can, like it's showing in the picture, open a clone of the Users eSpace and for example make a customized version of it if needed. However, I won't recommend you to do that, only in case it is really necessary.

The reason for this is because the original Users eSpace can change in the future and it will be updated by Outsystems when you perform a platform server upgrade. 

Your customized Users eSpace won't! So you will be stuck with the version it has when you've cloned it!

Regards,

Nordin