Paging is not working in service action

Hi

i am using service action to fetch data from database.and that data i am storing in local variable and datatype is same as Service action output.that local variable i am using to display data in grid but my paging is not working.i already changed the Paging thing.for paging purpose any another thing we have to do.please find the below screenshot.

Hi Arkyadeep Bharadwaj,

Set the start index of the List record Widget like this

List_Navigation_GetStartIndex(SuuchiRecords.Id,RememberStartIndex:,StartIndexOverride:)

Hope this will helps you.

Regards,

Koushik

Koushik Prathi wrote:can you please clarify this thing.its not clear.we have to set in reset startindex 

Hi Arkyadeep Bharadwaj,

Set the start index of the List record Widget like this

List_Navigation_GetStartIndex(SuuchiRecords.Id,RememberStartIndex:,StartIndexOverride:)

Hope this will helps you.

Regards,

Koushik



Solution
List_Navigation_GetStartIndex(SuuchiRecords.Id,RememberStartIndex:,StartIndexOverride:)

Set the start index property of the List Record Widget like above

On the OnNotify action of the List Navigation Widget follow the below pattern.

This worked for me. attaching sample file for reference.

Regards,

Koushik

Solution

Hi Kaushik

paging is working.but if i go to the page no 2 then we cant go page no 1.do u have faced this type issue

Hi Arkyadeep Bharadwaj,

No i never face this issue.Can you share the sample oml file which reproduces the issue.

Regards,

Koushik

Hi Koushik 

thanks for your support.i have done one mistake.now its working