OS10 Favicon not working even with AddFaviconTag

Hi Everyone,

I am using OutSystems10 software platform.

I want every tab in my application to be inserted with my own icon instead of OutSystems own. I have inserted AddFaviconTag action to Preparations, inspect web screen but there is still no link appended to head tag. I have also modified the favicon according to the methods in most of these OutSystems forum but the icon still does not refresh after published.

Please help!

Hi Chi Wei,

What you are doing should work, although I have had problems with some images, browser caching and forgetting to set the Deploy Action before.

Normally the best way to replace the favicon is by changing the existing favicon resource to your own favicon image.

  • Navigate to the Data tab
  • Under Resources, right click on favicon.ico and click Change
  • Then upload your own icon.

Make sure the icon resource has Deploy Action = Deploy to Target Directory.

This will change the favicon for all the pages of your application without having to modify the preparation for each page.

Sometimes I also find my browser will cache the favicon for a site.  I usually try another browser if I do not see the favicon change.

Otherwise, the Menu block is usually the place where the favicon is added for all pages.  You could change the favicon here as well.

I hope this helps.

Kind regards,


Hi Stuart,

I have already tried all methods. From changing the icon to deploy action to even rename destination url in full. There is once it works fine with the logo but the next day all icons are now back to OutSystems default icon.


Similiar issue here, it only works within the pages on theme module, even though I am setting the AddFavicon action on the preparation of a common block used in every page of the app. 

Never had this problem before, i have changed favicon many times in different apps since OS10 and never had any issue.

Would be nice to have some info on this from OS itself...