This eSpace uses a missing User Provider

Hi,

After our upgrade to OS11 (Cloud environment) we have create a few new mobile apps. In these applications all components after the first shows the following error;

I have already changed the User Provider from the default one (himself) to the Users provider but the error stays. It is not causing failures in my apps but I would like to get rid of the error. The configuration of the user provider looks as follows;

I have updated all my references to make sure that everything is up-to-date.

Has anyone encountered this before and what was your solution?

Hi Vincent,

After the fix you applied and publishing I'd expect the error to go away... this is odd behaviour. what do you see in Service Center and/or LifeTime? Is everything fine there or the error displays across the board on Service Studio, Service Center and LifeTime? 

Hi Jorge,

Of course I published my changes but this didn't solve the error. I have checked the application in both LifeTime as Service Center and I see the exact same error in here;

Lifetime:


Service Center:


Hi Vicent,

You should contact Outsystems support here.

Regards,

Marcelo

Hi Marcelo,

I have made one. I will update this thread if and when it's resolved. 

Best,

Vincent Koning

Just want to add that this is not a one off. We are also having this issue. Please post any workaround or solution when you find one.

No solution yet?

Not even a reply on my support ticket. I was about to poke them ;) 

edit: I added it as a "low" priority since it doesn't have any impact as far as I know. They have 4 more days before a response is expected.

Hi,

We had this problem sometimes too. What I did to fix it is:

  1.  exporting the module
  2. removing it
  3. importing it again
  4. publish it

Regards,

Daniel

I *also* have this error and a ticket open on it.

J.Ja

Justin James wrote:

I *also* have this error and a ticket open on it.

J.Ja

HI All,

Kindly note that many of my colleagues including me also facing this issue , I have also raised support ticket & awaiting for solution.

Please suggest if any one has got any workaround for this issue.


Please find OAP for the reference.


Daniël Kuhlmann wrote:

Hi,

We had this problem sometimes too. What I did to fix it is:

  1.  exporting the module
  2. removing it
  3. importing it again
  4. publish it

Regards,

Daniel


This worked!

Hi Rosanne,

Thanks for quick support.

I have followed the steps suggested by Daniel.. after publishing the same as such I didn't get any error message on service center . But once I imported the same & started working , I got the same error which I was getting earlier .

Error stating that Server Action is unavailable due to missing dependencies . Open & fix  API_Connector module.

I rechecked with the module & I didn't find any dependencies missing . But still issue exists.


I have already uploaded the OAP file in the trail post for reference

Please find the snapshot of error message attached.


Thanks & Regards,

Dishant Deep

Dishant Deep wrote:

Hi Rosanne,

Thanks for quick support.

I have followed the steps suggested by Daniel.. after publishing the same as such I didn't get any error message on service center . But once I imported the same & started working , I got the same error which I was getting earlier .

Error stating that Server Action is unavailable due to missing dependencies . Open & fix  API_Connector module.

I rechecked with the module & I didn't find any dependencies missing . But still issue exists.


I have already uploaded the OAP file in the trail post for reference

Please find the snapshot of error message attached.


Thanks & Regards,

Dishant Deep

Hi Dishant, 

I think this is another issue than the title of this subject. I have looked into it, and I think it has something to do with the EmployeeId in the action ValidateValidRequest. In IIFLCalculation_Eng you have to make a reference to the module that contains the employee table.  

Hi Rosanne,

Thanks a lot for your guidance . I looked into my code & found some logical mistakes as you suggested , now it's working fine.

And Thanks to Daniel too .. His suggestions resolved my platform version mismatch issue.

@vincent still no update on your support ticket?

None, And I'm about to go on my holiday so I will not be reading my mail a lot. Updates will comes sparingly. 

If you create a new version of the solution and redeploy it, should resolve the problem.

I already got an update for this problem from support. It's a bug in the platform and a fix will be made in the future. For now they fixed my problem manually so I could continue without any issues.

already??? :)

I am not someone who complains fast but when you have to wait almost 3 months to get your ticket solved....

I just didn't update this thread. My holiday was during this time frame and I just completely forgot about it. 

Vincent Koning wrote:

I just didn't update this thread. My holiday was during this time frame and I just completely forgot about it. 

Thanx for explaining. Gives me more trust in OS support. ;)

Can you elaborate a bit more on the issue? We will be upgrading somewhere next month and if there is anything i can do to avoid having this issue that would be great.


As far as I know there is nothing you can do. It's an internal OutSystems issue and I'm not sure if this is an edge case or a more common one. Should you run into this issue then send me a message and I will give you my ticket number for reference. This can speed up support because they don't need to analyse the issue again. 

It's simply a confusing error message. There is no actual problem. I would not hesitate to deploy or upgrade a project or the platform over this issues.

J.Ja

As a heads up, I did get a response from support a few days ago... it's going to be fixed in future versions and they have a SQL script that can be used to clear the error message.

J.Ja

Justin James wrote:

As a heads up, I did get a response from support a few days ago... it's going to be fixed in future versions and they have a SQL script that can be used to clear the error message.

J.Ja

Hi Justin,

Where I can find the " SQL script that can be used to clear the error message" ?


Best regards,
RM


Ruben Machado wrote:

Justin James wrote:

As a heads up, I did get a response from support a few days ago... it's going to be fixed in future versions and they have a SQL script that can be used to clear the error message.

J.Ja

Hi Justin,

Where I can find the " SQL script that can be used to clear the error message" ?


Best regards,
RM


File a support ticket. I don't feel comfortable sharing a SQL script that support provided directly to me.

J.Ja