Forge Component
(11)
Published on 13 Jun by OutSystems R&D
11 votes
Published on 13 Jun by OutSystems R&D

Hi,

After the recent update of Pushwoosh,

I am getting this error


Is this an issue from plugin or should i need to modify anything from my application end?


Thanks,

Keerthi

Hi Keerthi,

Please try below solution :


It could be due to the updated version of pushwoosh plugin which is not compatible with MABS vesrion.

You may try below steps :

1. Go to the component's Forge page;
2. Download the version 4.1.1 marked as "Under Development" - please be aware that you need to select the version for OutSystems 11;
3. Open the downloaded ".oap" file in Service Studio, while logged in into your environment - this will update the "Pushwoosh Plugin" component;
4. Refresh the dependencies for "Pushwoosh" in your "Landus Cooperative" mobile application and make sure that you have followed all the steps from the "How to Use Push Notifications with Pushwoosh" article. Be aware that you will need to upload the "google-services.zip" file to the resources your mobile app;
5. Publish your mobile application;
6. Regenerate your application with MABS 5;

Thanks,

Vani

Vani Mankad wrote:

Hi Keerthi,

Please try below solution :


It could be due to the updated version of pushwoosh plugin which is not compatible with MABS vesrion.

You may try below steps :

1. Go to the component's Forge page;
2. Download the version 4.1.1 marked as "Under Development" - please be aware that you need to select the version for OutSystems 11;
3. Open the downloaded ".oap" file in Service Studio, while logged in into your environment - this will update the "Pushwoosh Plugin" component;
4. Refresh the dependencies for "Pushwoosh" in your "Landus Cooperative" mobile application and make sure that you have followed all the steps from the "How to Use Push Notifications with Pushwoosh" article. Be aware that you will need to upload the "google-services.zip" file to the resources your mobile app;
5. Publish your mobile application;
6. Regenerate your application with MABS 5;

Thanks,

Vani


Hey Veni,


Thanks for your response.

But i am already using the version 4.1.1 only and followed all the guidelines as per pushwoosh and app is generated in MABS 5 only. Still that issue occurs.


Thanks,

Keerthi

Can you please check the extensibility configuration of pushwoosh plugin ?


{
    "plugin": {
        "url": "https://github.com/OutSystems/pushwoosh-phonegap-plugin.git#7.13.0-OS1",
        "variables": [
            {"name": "IOS_FOREGROUND_ALERT_TYPE", "value": "BANNER"},
            {"name": "ANDROID_FOREGROUND_PUSH", "value": "true"}
        ]
    }
}

Its Exactly the same