I've been working on my project with outsystems the past 2 weeks non stop but suddenly when I tried to enter home I was redirected to an outsystems page saying it was inactive for some time. I clicked wake but the website does not load.


I was inspecting service center and I've run into a couple of error, the first one is the one that makes me the most worry.


Other:

Hi David,


Just to be sure, could you check the following:

- if the problem is solved by re-publishing the application (either in Service Center or in Service Studio),

- what the database size is according to LifeTime? 


As for the status of the User module, you could refer to this documentation page: Applying Configurations in Service Center.

1. I cant publish or deploy it never finishes loading.

2. Aparrently I've used 2273 MB used out of 2 GB.

Monique de Vos wrote:

Hi David,


Just to be sure, could you check the following:

- if the problem is solved by re-publishing the application (either in Service Center or in Service Studio),

- what the database size is according to LifeTime? 


As for the status of the User module, you could refer to this documentation page: Applying Configurations in Service Center.



I've deleted a lot of stuff on service center, factory espaces, every change that is more than one week has been removed but the database is still at 110%

Hi David,

When the database size exceeds 2GB, an environment can switch to the inactive status immediately. It's a bit deceptive that the message you get is the same one you receive when having an actually inactive environment. Waking up the environment usually gives a bit more room to stretch and make a few modifications to the environment in order to clean it up.

You can use the DBCleaner Forge component (or the DB Cleaner on Steroids) to clean up your database. When selecting a time period over which to delete previously published versions, setting a negative value will allow you to clean all versions up to now (as opposed to up to a week ago). No active versions will be deleted unless you explicitly specify it (iirc).

To prevent clogging up an environment in the future, you could limit publishing new versions, make it a habit to clean up regularly, or set timers to do it for you. 

(If you can't use the database cleaner modules from the Forge, you can always contact Support to find a different solution.)

David Oliveira wrote:

I've deleted a lot of stuff on service center, factory espaces, every change that is more than one week has been removed but the database is still at 110%

Sometimes LifeTime needs a bit of time to reflect the changes in database size (or maybe it's the database itself which resizes on a timer, I can't remember). As long as you can publish and access your site again, it's probably all good!

I guess I will wait then.. But I still cant deploy or access my website. 

Monique de Vos wrote:

David Oliveira wrote:

I've deleted a lot of stuff on service center, factory espaces, every change that is more than one week has been removed but the database is still at 110%

Sometimes LifeTime needs a bit of time to reflect the changes in database size (or maybe it's the database itself which resizes on a timer, I can't remember). As long as you can publish and access your site again, it's probably all good!

Nothing yet, I've opened a support ticket. I hope they see it fast as it is a really important project.