[OutSystems UI] Version 2.1.0 cannot be installed in 11.0.424.0

Forge Component
(57)
Published on 12 Jul (6 days ago) by OutSystems R&D
57 votes
Published on 12 Jul (6 days ago) by OutSystems R&D

Hi, 

Version 2.1.0 cannot be installed in 11.0.424.0.


Uploading eSpace OutSystemsUI.

Unsupported newer version 11.0.415.100
Details : OutSystems.Oml.UnsupportedNewerVersion: Unsupported newer version 11.0.415.100
at OutSystems.Oml.Oml.cmn#juxsaosy()
at OutSystems.Oml.Oml.cmn#juxsaosv(Stream zi, String zj)
at OutSystems.Oml.Oml.cmn#juxsaosq(Stream ys, Boolean yt, String yu)
at OutSystems.Oml.Oml.cmn#juxsaoss(Stream yy, Boolean yz, ObjectKey za, String zb, Boolean zc, IInformationForESpaceUpgrade zd)
at OutSystems.Oml.Oml..ctor(Byte[] buffer, String productKey, IInformationForESpaceUpgrade informationForUpgrader)
at OutSystems.HubEdition.DeploymentController.Compiler.UploadEspace(ICompilerContext context, Int32 userId, Byte[] omlBytes, Int32 catalogId, ObjectKey applicationKey, Boolean replaceEspaceWithSameName, String commitMessage, Int32& espaceId, Int32& espaceVersionId, Int32& versionNumber, Boolean& basedOnPreviousVersion, Boolean& existsWithDifferentKey, HEMessageArrayList& messages).
Solution

Hi Romeu,

You’ll need the latest version of platform server to install this last version of OutSystems UI. (despite the numbers of the versions being misleading)

Cheers,

Tiago Simões 

Solution

Same issue on personal environments as they seem to still be on 11.0.212.0 for teh moment

Yes. My advice would be to update using the bell on Service Studio start screen. This will warn and update the components to the latest version that is compatible with your environment. 


Cheers,

Tiago Simoes 

Tiago Simões wrote:

Hi Romeu,

You’ll need the latest version of platform server to install this last version of OutSystems UI. 

Cheers,

Tiago Simões 


Hi Tiago,

But in this case than the Requirements should be changed, now it says : "Requirements Platform:11.0.0.200"

And I looked at the change description, and for me "Upgraded to OutSystems platform 11.0.523.0" it seams like it was published in this version and not that i need this version so i can install this.


Many Thanks,

Romeu Azevedo

Hi Romeu,

Yes, you are right, the message is very misleading. Unfortunately we can't fix it for the platforms server versions that are already installed. After you upgrade the platform server not only the problem with publishing OutSystems UI will go away, but you'll never get those strange messages again, you'll get messages that are a lot more explicit.

Cheers,
Tiago Simões