Error happen when consume SOAP Web Service

Hi all,

As I mentioned above, when I try to consume SOAP method, OS popup this error "There was no endpoint listening at ....that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details."

I think I input URL WSDL correctly when consuming web soap service because it returns exactly method I want to consume.

But when I run this method in client action, this error happens. I don't understand why ?

+ Expose SOAP Web Service

 

+Consume SOAP Web Service

Regards,

Huy Nguyen,

Hi,

Can you first make a try in Postman and getting the same error?

Please check the WSDL. I hope there is something wrong.

Sourav Pasari wrote:

Hi,

Can you first make a try in Postman and getting the same error?

Hi Sourav Pasar,

Can you guide me how to send SOAP request in PostMan?

I have only used Rest API in PostMan before.


Thanks,

Sudip Dey wrote:

Please check the WSDL. I hope there is something wrong.

Hi Sudip Dey,


How to check and know whether WSDL has error or not?


Thanks,


Hi all,

When I try to consume again today, it works

I don't know why.  

Thank all,

 

Huy Nguyen wrote:

Hi all,

When I try to consume again today, it works

I don't know why.  

Thank all,

 

I hope that's the issues of the Server from where you Consume the SOAP. That's why I told you that the issues of the WSDL. Glad to hear that it is resolved.


Huy Nguyen wrote:

Hi all,

When I try to consume again today, it works

I don't know why.  

Thank all,

 

Hi Huy Nguyen

I guess the server which hosts those services was down when you try to consume it.
It's better to handle those exceptions whenever possible, then you don't need to worry about them in future. Cheers