Hi everyone.

I am having an issue with a style in iOS 10.3x. Apparently this version had some changes in the UIWebView, but I am not sure if its related. What i have is simply some buttons that are absolute positioned in the screen and they are perfectly aligned everywhere in every phone, except iphones with 10.3x, where they are too down and one of them ain't even showing because its below the viewframe.

Is this an exclusive Apple issue or can i do something to fix this?

Might help if you could share an OML that reproduces the issue, or at least the styles you're using.

Hello Andrew.

 At the moment i cannot share an OML, but as for the styles i compiled a text file you can see in the attachment.

Hope its enough to help understand the issue.

Is the issue specific to just version 10.3.x, or do you see it in that version and older versions as well?

One thing I noticed was the use of device-aspect-ratio in the media query, which made me wonder whether that might be supported in older iOS Safari versions.

Unfortunately, I don't have an iOS 10.3.x device to test against, so I can only offer general advice on potential issues in the CSS.

G. Andrew Duthie wrote:

Is the issue specific to just version 10.3.x, or do you see it in that version and older versions as well?

One thing I noticed was the use of device-aspect-ratio in the media query, which made me wonder whether that might be supported in older iOS Safari versions.

Unfortunately, I don't have an iOS 10.3.x device to test against, so I can only offer general advice on potential issues in the CSS.

Yes you maybe right, i forgot about that. I will change that media query and see how it develops. Good advice.

Edit: replacing the media query didn't help...it still has the exact same problem.