I have something to ask about REST API Method


I am learning how to integrate with an existing REST API, using OutSystems.

I'm currently on the Exercise material "10.2x Web Services Exercise.pdf ".

I cannot display the movie poster image like the top right movie poster image on the above second image. As you can see the first insert image, the area of square that the movie poster should be displayed remains the color of gray......

I assume I can't extract the movie poster image URL.


But I cannot figure out this glitch.
What is the first step?

I have attached the zip file including "10.2x Web Services Exercise.pdf ".

BTW,The second insert image is on the page12  of  the PDF file.

I'd appreciate it if you could give me how to figure out that glitch !


I look forward to your reply!


Solution

Hi Tsubasa,

What have you done to find this problem yourself? Have you debugged? Have you checked what URL the REST call returns? If so, how do you display the image based on the URL on your Screen?

Solution

Kilian Hekhuis wrote:

Hi Tsubasa,

What have you done to find this problem yourself? Have you debugged? Have you checked what URL the REST call returns? If so, how do you display the image based on the URL on your Screen?

Yes. I have debugged.   I got that glitch after I clicked the 1-Click Publish button and published the application.

How do i check what URL the REST call returns?


Hi Tsubasa,

You say you have debugged, but then you say you don't know how to check the URL, which leads me to believe you haven't debugged. So add a breakpoint to the right location, start the debugger, run the app and see what values are returned.

Note that we're here to help you with OutSystems-related questions, but we also assume you have a basic training in software development, so you know what things like "debugging" actually mean.