Hi,

I want install LifeTime server on local network. In first step of installation SSL is required.

I can't install valid SSL on local network.


Hi Davod,

You may install the Self-Signed Certificate and continue with the LifeTime installation.

Regards,

Swatantra

Davod, it's important to secure LifeTime with a valid certificate. The source code of all your applications will be transferred to that server. You don't want to have a man-in-the-middle capturing your valuable work.

Having a self-signed certificate could work for you if you secure the private key. In general, though, you will be better off with a trusted certificate - they are not so expensive, especially when compared to OutSystems' licensing costs.

From OutSystems 11, It's the prerequisites to have a secured connection. It says

  • Both LifeTime and the OutSystems environment servers are configured to establish secure connections (https).

It's always recommended to have a CA signed certificate, but you have an option to go ahead with self-signed certificate. Steps for installation of Self-singed certificate is mentioned above.

Swatantra Kumar wrote:

From OutSystems 11, It's the prerequisites to have a secured connection. It says

  • Both LifeTime and the OutSystems environment servers are configured to establish secure connections (https).

It's always recommended to have a CA signed certificate, but you have an option to go ahead with self-signed certificate. Steps for installation of Self-singed certificate is mentioned above.


Hi,

Thanks for your reply.

I built a self signed certificate but still problem not solved!

Please see the attached image

Davod,

The 1st address is the address of the environment you are trying to register (eg:. dev.mydomain.com), it must be an ip or fqdn instead of localhost.

The 2nd address is the fqdn of lifetime itself 9eg: lifetime.mydomain.com) that will be used by the new environment to communicate back to lifetime, also, must be an ip or fqdn instead localhost.

Both need to have trusted certificates, so if you are using self-signed certs for both, export and install the certificate from one to the other.

cheers

davod Ughlu wrote:

Swatantra Kumar wrote:

From OutSystems 11, It's the prerequisites to have a secured connection. It says

  • Both LifeTime and the OutSystems environment servers are configured to establish secure connections (https).

It's always recommended to have a CA signed certificate, but you have an option to go ahead with self-signed certificate. Steps for installation of Self-singed certificate is mentioned above.


Hi,

Thanks for your reply.

I built a self signed certificate but still problem not solved!

Please see the attached image

Hi Davod,

Use fully qualified name instead of locahost (Arley also indicated same). After that, export and install the certificates on cross environments to trust it.


Swatantra Kumar wrote:

davod Ughlu wrote:

Swatantra Kumar wrote:

From OutSystems 11, It's the prerequisites to have a secured connection. It says

  • Both LifeTime and the OutSystems environment servers are configured to establish secure connections (https).

It's always recommended to have a CA signed certificate, but you have an option to go ahead with self-signed certificate. Steps for installation of Self-singed certificate is mentioned above.


Hi,

Thanks for your reply.

I built a self signed certificate but still problem not solved!

Please see the attached image

Hi Davod,

Use fully qualified name instead of locahost (Arley also indicated same). After that, export and install the certificates on cross environments to trust it.



Let me check once I wrote an article on our intranet for the same issue you described. If it's still there, I'll send you as help.

Swatantra Kumar wrote:

Swatantra Kumar wrote:

davod Ughlu wrote:

Swatantra Kumar wrote:

From OutSystems 11, It's the prerequisites to have a secured connection. It says

  • Both LifeTime and the OutSystems environment servers are configured to establish secure connections (https).

It's always recommended to have a CA signed certificate, but you have an option to go ahead with self-signed certificate. Steps for installation of Self-singed certificate is mentioned above.


Hi,

Thanks for your reply.

I built a self signed certificate but still problem not solved!

Please see the attached image

Hi Davod,

Use fully qualified name instead of locahost (Arley also indicated same). After that, export and install the certificates on cross environments to trust it.



Let me check once I wrote an article on our intranet for the same issue you described. If it's still there, I'll send you as help.

Thanks sir,

I use air gapped machine and i can't use fqdn.

I am waiting for your article about solving this issue.

Also i saw and used link that you sent about self signed certificate but unfortunately i couldn't create a valid personal certificate.

Also I read some article about self signed certificate but none of them wasn't helpful.


Thanks



Quick check on google suggested below link explaining generation, binding, trusting the self signed certificate.

https://www.sslshopper.com/article-how-to-create-a-self-signed-certificate-in-iis-7.html

davod Ughlu wrote:

Swatantra Kumar wrote:

Swatantra Kumar wrote:

davod Ughlu wrote:

Swatantra Kumar wrote:

From OutSystems 11, It's the prerequisites to have a secured connection. It says

  • Both LifeTime and the OutSystems environment servers are configured to establish secure connections (https).

It's always recommended to have a CA signed certificate, but you have an option to go ahead with self-signed certificate. Steps for installation of Self-singed certificate is mentioned above.


Hi,

Thanks for your reply.

I built a self signed certificate but still problem not solved!

Please see the attached image

Hi Davod,

Use fully qualified name instead of locahost (Arley also indicated same). After that, export and install the certificates on cross environments to trust it.



Let me check once I wrote an article on our intranet for the same issue you described. If it's still there, I'll send you as help.

Thanks sir,

I use air gapped machine and i can't use fqdn.

I am waiting for your article about solving this issue.

Also i saw and used link that you sent about self signed certificate but unfortunately i couldn't create a valid personal certificate.

Also I read some article about self signed certificate but none of them wasn't helpful.


Thanks




"Air graped" Interesting. Has it any (static local) IP address (when it comes to network)?

I use local network on Domain service. My static ip : 192.168.10.24

Solution

SSL certificates are bound to a 'common name', which is usually a fully qualified domain name but can be an IP address. You may issue the certificate to the IP and go through the process of cross binding to trust.

Solution