I cant refresh the changes on the entities

Hi, I want to create a change, I want to link a commnets entity with the User one, I can do it on the Core module but changes can´t be seen on the module I´m working on. I can see on the diagram the relationship created but there is no refresh button anywhere...

Hello,

Did you try to refresh your dependencies on the module your working on?


You can refresh the individual reference or presh the 'refesh all' and 'apply' button


Regards,

Thomas


Hi Jhon,


so you see your change in the dependency window, but not yet in te datamodel of your consumer module, and there is no little blue arrow on the producer module to refresh? and the refresh button at the bottom is grayed out ??

not sure why this happened, but what you could try is to uncheck the table from the dependencies, and choose apply, then go in again and check it and apply.

good luck,

Dorine

Hi, that created a real mess.

Thomas Druif wrote:

Hello,

Did you try to refresh your dependencies on the module your working on?


You can refresh the individual reference or presh the 'refesh all' and 'apply' button


Regards,

Thomas


Hi, I wanna, but threre is no refresh button


I didn't quite understand the question, if I'm wrong please give me more details:


- Create the entities and make the relationship, add to the diagram just so you can visually see how the relationship is being made.

- After creating these relationships, you have basically two ways to consume, leave public entities and make logic in the layer you want to use or create a server action in the Core layer leaving it public to be consumed in the UI module or View.

- After you have updated the dependency, then in your UI action or View just put a refresh data after entering the information in the desired entities.