where to check the application url is going wrong

Hi Team

Issue:-The issue is that when we are hitting the url e.g https://applicationname/ its working fine for the first time.But then when waiting for long like half an hour then again hitting the link like refreshing the link on same tab and browser the link is getting changed to https://https//applicationname/.This is happening in Internet explorer.

  1. Is it happening only on IE?
  2. Are you accessing same URL, same page?

Hi Divya,

Are you logged when you do this?
If you wait more than 20 min, the session will time out, and if you are trying to reach a page that requires authentication, a security exception will be raised by the application.

When this happens, you are redirected to the Global Exception Handler (as you did not reach any page yet), and in it, usually, there is a Security Exception handler, that will redirect you to the NoPermissions page, where, in the preparation, it will verify if you are logged or not, and will redirect you to the appropriate page (Invalid Permissions or Login).

So, you can put breakpoints on those places, and start debugging the application, doing as you told you did.
And investigate what is happening.

Hope this helps.

Cheers.

I think there are some setting issues of your server configuration. Please check it with the OutSystemssupport sharing your screenshot. It will solve your problem. 


Thank you,

Sudip

Swatantra Kumar wrote:

  1. Is it happening only on IE?
  2. Are you accessing same URL, same page?

1.Yes

2.Yes


Eduardo Jauch wrote:

Hi Divya,

Are you logged when you do this?
If you wait more than 20 min, the session will time out, and if you are trying to reach a page that requires authentication, a security exception will be raised by the application.

When this happens, you are redirected to the Global Exception Handler (as you did not reach any page yet), and in it, usually, there is a Security Exception handler, that will redirect you to the NoPermissions page, where, in the preparation, it will verify if you are logged or not, and will redirect you to the appropriate page (Invalid Permissions or Login).

So, you can put breakpoints on those places, and start debugging the application, doing as you told you did.
And investigate what is happening.

Hope this helps.

Cheers.

No before logging in.Its coming on simple url refresh.But the url is also coming wrong on screen and url refresh.


Hi Divya,

 Did you have included any javascript code for url redirection in the project?