Unusual error to do with my "Users" dependency being old or missing

I was just publishing my latest project when I noticed an unusual error. It read "Incomplete Upgrade
Module 'Users' was deployed with an old OutSystems Server version. Please publish 'Users' to fix it." I tried to refresh all my dependencies and went directly to "Users" to try and solve the issue but nothing changes. So far this hasn't affected anything majorly but I'm worried I may have issues in the future, how do I fix this?

Solution

Hi Micheal,

I had this problem recently in my personal environment and fixed it by republishing the lastest published version of the Users Espace in Service Center.

Solution

Hi Michael, 

Daniel already gave the solution, but I would like to point that this is a common problem usually connected to server upgrades. 

Any system component that becomes outdated after a server upgrade can be republished from Service Center (like showed by Daniel) and this usually solves the problem. 

You can create a solution if there is none already, and publish everything at once. 

Cheers. 

Eduardo Jauch wrote:

Hi Michael, 

Daniel already gave the solution, but I would like to point that this is a common problem usually connected to server upgrades. 

Any system component that becomes outdated after a server upgrade can be republished from Service Center (like showed by Daniel) and this usually solves the problem. 

You can create a solution if there is none already, and publish everything at once. 

Cheers. 

Thanks so much, this is a big help.


If any of the answers did solve your problem you can mark it as solution.