Hi all, just started on Outsystems and currently facing issues at one of the modules exercises at 6.6, step g as shown below;

"In the Canvas, click next to the recently created Expression, and type a comma and a space. Ensure these two characters are after the Link, but still inside the List Records."

I am unable to produce the widget tree as then shown below in the attachment. 

Not only that, I then keep getting an internal error when on the browser.

Any help with this is highly appreciated. 



Hi Ken,


welcome to the OS forum.  

It would be easier for us to help you if you provide more information of what exactly it is you are doing.  You could attach the oml of your project to the post :

1) open your module

2) choose menu Module>Export>SaveAS...

3) 'choose file' button under post edit field


If that's not possible, at least add some screenshots (you can add them into the post body with the image tag)


In this case a screenshot of your widget tree (fully expanded) would be usefull, one of the part of your canvas where the List Records is added.


When you are getting internal errors, you can log in to service center and see details about it.  You maybe haven't covered that in your course.  I'm assuming you are using a personal environment, so go to https://yourservernamoutsystemscloud.com/servicecenter.  (obviously, I don't know what the bold part is in your case, you can find it in the bottom right corner of OS Studio, see yellow in this picture)


 

You'll need to log in, and can then go to monitoring tab / errors.  most recent errors are at the top, and you can view error details by choosing Detail at the end.

When asking in the forum about an error you are getting, it is always usefull to add a screenshot of these error details. 


So, give us some more info, and we'll try to help you along,

Dorine


Hi Dorine,

This information is well noted. Attached is the following .oml file from my Outsystem module. 

I have tried going through the G step as shown above in my lab works but am unable to proceed. Can't seem to ensure the "comma and space " is done after the link. With this, my widget tree is not the same as shown in the result above from the tutorial. 

With this, I am suppose to get results as shown in step k) in the screenshot above however, I am currently getting an internal error as shown as below;



Currently new with outsystems and am learning more with this tutorial of data queries and widgets II.


Thank you. 

Hi Ken,


first your biggest problem : the internal error.  As the screen says, it is logged, so you can go to your service center and see details about what exactly went wrong (as explained in previous reply)  

But in this case, you can already see what's wrong in your oml : Look at the TrueChange tab at the bottom of your screen, it says that you have 1 Warning, and if you doubleclick the warning, it will even bring you to the problem

OS thinks there is something wrong with your SQL because there's all kinds of ' ' in it. And OS is right.  I ran your code As Is, and this is the error detail :

Error executing query. Error in advanced query GetCastAndCrew in Preparation in MovieDetail in MainFlow in OSMDb (SELECT {Person}.[Id], {Person}.[Name] + ' ' + {Person}.[Surname] Fullname   FROM {Person}      JOIN {PersonMovieRole} O N {PersonMovieRole}.[ PersonId] = {Person}.[Id]       JOIN {PersonRole} O N {PersonRole}.[ Id] = {PersonMovieRole}.[PersonRoleId]   WHERE {PersonMovieRole}.[ MovieId] = @MovieId      AND {PersonMovieRole}.[ PersonRoleId] IN (@ ActorRole, @CrewRole)   ORDER BY Fullname ): Incorrect syntax near 'N'.

When you have sql in your project, it is really usefull to execute a test while developing, this problem would already show up sooner, and you would not be at a loss about why you are getting errors.  You can give test values on the Test Inputs tab for each of the input variables involved.  As you see below, you already get early feedback that something is wrong with your query:

Now for the reason : 

You probably copied and pasted the SQL from the pdf into your project.  Turns out that when viewing the PDF with certain browsers, all kinds of (invisble) characters are added (I found out the hard way later on in the course with the CSS)  Best thing to do is to manually type all code like css and sql during your exercises instead of copy paste.  So that should solve your 'internal error' problem.


The other problem is easier.  You want to add a text field ", " between the items in your CastAndCrew ListRecords.  And it might be a bit hard to drag a text widget to the right spot, right ?  

option 1 : One of the things you can use, is the fact that when the cursor is somewhere in the Canvas, and you start typing, it will add a text widget automatically.  So 

  • click on the PersonFullName Expression inside the Source Record List in your Canvas
  • press right arrow on your keybord
  • type a comma and a space


option 2 : When it is hard to get something at the right spot on the canvas, you can add it through the widget tree instead.

  • open the widget tree
  • right-click on the CastAndCrewList Source Record List
  • choose menu Insert Widget > Text
  • a text with value 'text' is added, click on it to change it to a comma and a space


Hope this helps you further along on your learning path,

enjoy,

Dorine





Hi Dorine,


I have read through your explanation and words cannot express how much you have helped me out. I am trying out back the problem as we speak and retracing it back to the SQL step mentioned. 

Just started out Outsystems within these few days and have learned so much throughout the theories and tutorials. Thank you so much for replying this forum and making this experience so worthwhile. 


Regards, 

Ken

Hi Ken,

happy to help.  

If you feel a post solved your problem, marking it as a solution can express that it helped you :-)