A glitch when deleting data from the list

I have a problem with "Delete function to delete data from a list".

I'm guessing I have a glitch when I delete the specific data from the list like above.

Do you have any ideas to make this kind of  Delete function happen properly?

I have attached my .oap file here. 

I hate to seem pushy but I was wondering if you could take a look at my module and revise the wrong parts.


If you have any questions, feel free to ask me !

I look forword to your reply!

Best regards,

Hi Tsubasa,

In the screen action which handles the Delete operation in QADetails webpage, after deleting the record in the target entity, you need to have a destination node and set the webpage 'QAList' in the destination. This will redirect the user back to the QAlist webpage after deleting the record.

Thanks

Karthik Jeyaraman wrote:

Hi Tsubasa,

In the screen action which handles the Delete operation in QADetails webpage, after deleting the record in the target entity, you need to have a destination node and set the webpage 'QAList' in the destination. This will redirect the user back to the QAlist webpage after deleting the record.

Thanks

Thank you for telling me about it!

But I see what you mean but how do I set the destination in this case like above?

I know it is asking a lot,but I'd appreciate it if you could tell me about the way in detail.


Best regards,


Karthik Jeyaraman wrote:

Hi Tsubasa,

In the screen action which handles the Delete operation in QADetails webpage, after deleting the record in the target entity, you need to have a destination node and set the webpage 'QAList' in the destination. This will redirect the user back to the QAlist webpage after deleting the record.

Thanks



Solution

Hi Tsubasa,

You can use the Destination widget to do the redirection

Do let me know if you'd like more help on this.

Happy to help.

Thanks & regards,

Boney


Solution

Tsubasa Yoshikawa wrote:

Karthik Jeyaraman wrote:

Hi Tsubasa,

In the screen action which handles the Delete operation in QADetails webpage, after deleting the record in the target entity, you need to have a destination node and set the webpage 'QAList' in the destination. This will redirect the user back to the QAlist webpage after deleting the record.

Thanks

Thank you for telling me about it!

But I see what you mean but how do I set the destination in this case like above?

I know it is asking a lot,but I'd appreciate it if you could tell me about the way in detail.


Best regards,


Hi Tsubasa Yoshikawa

      Its a simple thing replace the End as destination on just drag destinationon near to end  delete the end node replace it by destination and it asks for destination page set the page as you need ..


Thanks & Regards

Soundarya


Hi Tsubasa,

you really should consider taking more of the online video courses and exercises.  

This is very basic Outsystems behaviour.  See for example this video

If you are in a hurry, start watching at 9 minutes

Hi Tsubasa,

Please take the comment i will make as positive feedback.

Over the last days I noticed a lot of post from you, that almost always are very basic OutSystems questions.

The forum is for OutSystems developers who encounter problems will developing an application in OutSystems.

As such you can of course post a question and seek for help.

However, the forum is not the best place to learn OutSystems by posting basic questions.

OutSystems has an excelent learn site https://www.outsystems.com/learn/ with various guided paths.

In your case I would strongly advice to start and fully complete the guided path Becoming Web Developer, and maybe after that even Becoming a front-end developer in OutSystems

I can speak personally, that I learned as a beginner OutSystems developer a lot from these guided paths

After that I think most of all questions you have asked over the last days you would have been able to answer yourself.

Regards,

Daniel