[Firebase Mobile] Can´t generate app with the version 1.0.5, with MAPS 5.0

Forge Component
(16)
Published on 4 Nov (2 weeks ago) by David Sousa
16 votes
Published on 4 Nov (2 weeks ago) by David Sousa

I´m not able to generate my app with the newest Firebase Mobile, with MABS set to 5.0. It does work with the older MABS version 4.2. In the release note of Firebase Mobile version 1.0.3, It states that "Android builds with MABS 5 are now supported" on Outsystems 10. I´m currently using Outsystems 11.

This is the error I´m getting:
BUILD FAILED in 18s
Error: /opt/NativeBuilder/builds/2398d98a-ea8d-4cb4-9f30-ba3d8f281680/source/platforms/android/gradlew: Command failed with exit code 1 Error output:
Note: /opt/NativeBuilder/builds/2398d98a-ea8d-4cb4-9f30-ba3d8f281680/source/platforms/android/CordovaLib/src/org/apache/cordova/engine/SystemCookieManager.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':app:fabricGenerateResourcesDebug'.
> Crashlytics Developer Tools error.

Anuar Abdullahi wrote:

I´m not able to generate my app with the newest Firebase Mobile, with MABS set to 5.0. It does work with the older MABS version 4.2. In the release note of Firebase Mobile version 1.0.3, It states that "Android builds with MABS 5 are now supported" on Outsystems 10. I´m currently using Outsystems 11.

This is the error I´m getting:
BUILD FAILED in 18s
Error: /opt/NativeBuilder/builds/2398d98a-ea8d-4cb4-9f30-ba3d8f281680/source/platforms/android/gradlew: Command failed with exit code 1 Error output:
Note: /opt/NativeBuilder/builds/2398d98a-ea8d-4cb4-9f30-ba3d8f281680/source/platforms/android/CordovaLib/src/org/apache/cordova/engine/SystemCookieManager.java uses or overrides a deprecated API.
Note: Recompile with -Xlint:deprecation for details.

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':app:fabricGenerateResourcesDebug'.
> Crashlytics Developer Tools error.

Hi Anuar,


Please check below links for update. It may helps you or please write a support case for the same below...

https://www.outsystems.com/forums/discussion/47810/announcing-mabs-5-0-beta/

https://success.outsystems.com/Support/Enterprise_Customers/Troubleshooting/Troubleshooting_Issues_with_MABS_5.0

https://success.outsystems.com/Support/Enterprise_Customers/Troubleshooting/MABS_Upgrade_Troubleshooting_Guide_-_Android


Thank,

Dileep