i need to know how to prevent Cache for register Page ??

Hi Amr,

What do you mean with 'Register page'

Regards,

Daniel


Daniël Kuhlmann wrote:

Hi Amr,

What do you mean with 'Register page'

Regards,

Daniel



A custom Registration Form (in web page) used in my application 

Hi Amr,

Why do you want to prevent caching? Are you having issues with the browser back button? Have you seen this thread with possible solutions?

Hi, another way is to tell the browsers to not cache the page:

Here is what I did, for each page, I don't want to be retrieved from the cache on the browsers back button (or from history):

1. Add a call to the AddHeader action (from HTTPRequestHandler) in the preparation.
2. Set property as follow:

That's it.

This was tested on Chrome, Firefox, Edge and Opera.

Cheers.


Afonso Carvalho wrote:

Hi Amr,

Why do you want to prevent caching? Are you having issues with the browser back button? Have you seen this thread with possible solutions?

I want my custom Fields to be empty every time i entered this page , happens now it reads from the saved cache and i want to prevent that.



Hi Amr, 

Are you sure the problem is not something else? 

For example, if your page is a Detail page, with a form and inputs, you probably are passing (or should be) an Id as input parameter, so that you can edit a record (id is a valid identifier of an existing row), or you want to create a new record, and you pass NullIdentifier() as the value. 

Your aggregate must be filtered by this Id, like, if your entity is called Customer, and your input parameter is a CustomerId, you need a filter like this:

Customer.Id = CustomerId

And you set the source of the form to the GetCustomerById.List.Current.

If this page is only for create new records, you don't need the aggregate. Create a local variable of type Customer (just an example), and give it to the source of the form. 

Hope this helps. 

Cheers

Amr Ahmed wrote: 

I want my custom Fields to be empty every time i entered this page , happens now it reads from the saved cache and i want to prevent that.

If this is all you want, you can try adding "autocomplete=off" to your inputs, and this will instruct most browsers to not save the values there (not even in cached history versions). 

Just make sure your page can still function without running its Preparation, because it will not be executed when the user presses the back button.


Hi,

I think what Afonso Carvalho gives the suggestion is that will work as per your needs. Please check on it and let us know.


Thank you,

Sudip

Sudip Dey wrote:

Hi,

I think what Afonso Carvalho gives the suggestion is that will work as per your needs. Please check on it and let us know.


Thank you,

Sudip

That is not adding new relevant information.


Hi, 

Please check this below link and it will be the solution for you too.

https://www.outsystems.com/forums/discussion/40657/stop-form-from-remembering-previous-inputs/

Thank you,

Sudip