Error Message when I try to upload an excel file

Hi All,

I am trying to Upload an excel file and bootstrap it.

I get an error as per below, and cannot find the root cause.

Has Anyone experienced anything similar please?

Thank you in anticipation


Tasos

I can't see your error?

Stefano Valente wrote:

I can't see your error?

Hi Stefano,

Please see attached.

Thanks

T

the error is obvious: The Inetsrvr users doesn't have permission to access the folder. Or the excel is exclusively opened.


For bootstrap purpose i would put the excel in the outsystems resources...

Thanks Stefano,

and how do I do that "
For bootstrap purpose I would put the excel in the outsystems resources... " please?!

thanks

Tasos

Hi Anastasios,

You can place your Excel file in the Resources folder inside the Data tab of your Module:

And then afterwards, you can reference this binary data in your ExcelToRecordList action:

Afonso Carvalho wrote:

Hi Anastasios,

You can place your Excel file in the Resources folder inside the Data tab of your Module:

And then afterwards, you can reference this binary data in your ExcelToRecordList action:

Hi Afonso,

have you tried to upload anything please?

I cannot see the attachments.

Thank you

Taso



Solution

Hello Anastasios,

Just to talk about the error you were experiencing, I think usually this is related to have the document open in the Excel while trying to submit it. 

In any case, the bootstrap usually is done from within Service Studio. The online training has one of the exercises showing how to do it automatically.

You can also take a look here: https://success.outsystems.com/Documentation/11/Developing_an_Application/Use_Data/Bootstrap_an_Entity_Using_an_Excel_File

Cheers.

Solution

Hi Eduardo,

Thank you for your reply. I am aware that if you have the excel file open you cannot submit (run the bootstrap). So in my scenario that is not the case.

I will do further investigation on the suggested solutions and I will come back to you.

All the best,

Anastasios

I only attached some print screens, are they not showing up in the post? Let us know if you need further guidance.

No I cannot see them, sure I will let you know today thanks again for the support!