Service Studio Ask for Dependence

Hi there,

I have service studio 10.0.902.0 and it works well.

My friend's Service studio is also the same, but when it opens a module, there is always a modal that ask to update dependency.

How to fix it?

regards

Financial Freedom wrote:

Hi there,

I have service studio 10.0.902.0 and it works well.

My friend's Service studio is also the same, but when it opens a module, there is always a modal that ask to update dependency.

How to fix it?

regards

Hi Financial,


You check the modules permission? Maybe you have different permissions in those modules.


Best Regards,

Fábio Vaz


How to check it?

Financial Freedom wrote:

Hi there,

I have service studio 10.0.902.0 and it works well.

My friend's Service studio is also the same, but when it opens a module, there is always a modal that ask to update dependency.

How to fix it?

regards

Hello Financial,

Try this:-

In service studio, Go to "Manage Dependencies" and refresh all the dependencies you have in your Application.


Regards ,

Nandini


# Not like that, in my service studio, when i open the same module, it does not ask that update dependency modal.

# However, in my friend's service studio, the dependency modal window always pop up and when click there is an error.

Financial,


Try look at your lifetime and see what roles they have. Compare those roles with your Roles.


Best Regards,

FV

Financial Freedom wrote:

# Not like that, in my service studio, when i open the same module, it does not ask that update dependency modal.

# However, in my friend's service studio, the dependency modal window always pop up and when click there is an error.

If possible can you attach a screenshot of that popup window so that it will help to understand the issue better.

BR

Nandini


where in lifetime? tq

Nandini T S wrote:

Financial Freedom wrote:

# Not like that, in my service studio, when i open the same module, it does not ask that update dependency modal.

# However, in my friend's service studio, the dependency modal window always pop up and when click there is an error.

If possible can you attach a screenshot of that popup window so that it will help to understand the issue better.

BR

Nandini


Sorry, i did not capture just now. tq


Financial Freedom wrote:

Nandini T S wrote:

Financial Freedom wrote:

# Not like that, in my service studio, when i open the same module, it does not ask that update dependency modal.

# However, in my friend's service studio, the dependency modal window always pop up and when click there is an error.

If possible can you attach a screenshot of that popup window so that it will help to understand the issue better.

BR

Nandini


Sorry, i did not capture just now. tq



once check the status of the escape in service center. and also u can check the dependencies there,

Regards


Financial Freedom wrote:

where in lifetime? tq

Financial,

I am not sure to understand the issue,

you can check the "Environment Health" there and do refresh Data,





Solution

The role is same with the working one.

It seems that the history of the user has been deleted, and only left record in the past.

Could be the information lead outsystems to infer that the module independence is obsolete.

We fix it by creating new user.

regards and thanks


Solution