OutSystems 10 Carousel is BROKEN

Hey guys I'm just curious why it is, 

that from a default project your OutSystems carousel does not work?

It's really a waste of time always having to write styles to use the carousel. In a brand new project with only the carousel added as a dependency the carousel does not work. Why?
Why would you add something that out of the box does not even work? 

All the carousel image fall underneath each other and don't line up like a carousel is supposed to do?

This has been broken since I started using OutSystems a year ago. And the problem has never been fixed. I take it you guys are gonna never fix this? Or are you guys aware of it and just ignoring it?

I found that for some UI Themes it doesn't work. 

However: It's quite the challenge to change from London to Lisbon theme when your UI has been developed for most part.


However: You could duplicate your application and see if the carroussel works with the Lisbon theme.

Stefano Valente wrote:

I found that for some UI Themes it doesn't work. 

However: It's quite the challenge to change from London to Lisbon theme when your UI has been developed for most part.


However: You could duplicate your application and see if the carroussel works with the Lisbon theme.

Hi Stefano 

This is not an answer to the problem. It is broken. I want to know why it doesn't just work?

The amount my company pays for this software is ridiculous to be honest. But not my problem as it's not my bank account. At the end of the day why is this very expensive software not working?

It's a carousel for crying out a loud. How is it that OutSystems has a team of developers that can build an entire Low Code Platform but they cannot build a working Carousel?

It doesn't make sense why they can't build a carousel that works. Especially when they charge what they do.


I'm sorry.

I thought you had an issue and were looking for an answer so you could decide how to implement it in your solution.

As i said: The carroussel is working but might not work on your chosen UI theme. You can use that information to your benefit or just keep on bashing over here. Whatever works for you.


An Outsystems developer just trying to help you.

Regards,

Stefano


Stefano Valente wrote:

I'm sorry.

I thought you had an issue and were looking for an answer so you could decide how to implement it in your solution.

As i said: The carroussel is working but might not work on your chosen UI theme. You can use that information to your benefit or just keep on bashing over here. Whatever works for you.


An Outsystems developer just trying to help you.

Regards,

Stefano


Hey thanks for the help Stefano I do appreciate it. 

Sorry I'm not bashing on you, just wandering why I always have to write custom styles
to use a component that doesn't work. I feel like what the company charges it is
something that should just work.

I'm sure you can agree that something out of the box should work right? 

I shouldn't have to hack and slash new stuff to get it working right?


Ofcourse that can be annoying. Perhaps i can recommend you to upgrade to OS11?


The upgrade is free. You will get lots of new features and especially the UI has improved.

It's the best way to get bang for your buck.


Good luck!

Stefano Valente wrote:

Ofcourse that can be annoying. Perhaps i can recommend you to upgrade to OS11?


The upgrade is free. You will get lots of new features and especially the UI has improved.

It's the best way to get bang for your buck.


Good luck!

Yes I agree that to upgrade would be better but I am working for a large corporation and the guys in charge of our environment have been delaying the upgrade because they don't want to break anything.

If you were able to help me get our system to OutSystems 11 that would be great.But We have lots implemented in OutSystems 10 and I'm not sure if the upgrade is a simple task. 


My client will upgrade in 2 months. We have blocked 1 week for it.

If you are in the cloud you need to change server, database version and upgrade all your used components. And ofcourse do a full integration test on all environments.


But OS11 has many cool new features and upgrades. Its not a question if, but when you must upgrade.

Stefano Valente wrote:

My client will upgrade in 2 months. We have blocked 1 week for it.

If you are in the cloud you need to change server, database version and upgrade all your used components. And ofcourse do a full integration test on all environments.


But OS11 has many cool new features and upgrades. Its not a question if, but when you must upgrade.

I understand but what happens when one company doesn't upgrade? Surely there must be a cut off date for OutSystems 10?  I am stuck on OutSystems 10 because of the team I have to work with. If it's a matter of when then when? Will OutSystems 10 be cut off?

That will not be any time soon i think.


Last update was about 1 month ago.


Best is to ask these things to OS directly: submit a ticket.

Stefano Valente wrote:

That will not be any time soon i think.


Last update was about 1 month ago.


Best is to ask these things to OS directly: submit a ticket.

But then if it's not anytime soon will someone look at fixing this carousel issue in OutSystems 10 or is just going to be ignored? 

It's been like this for ages and nothing has been fixed? 

I can't upgrade the environment so therefore someone needs to fix this issue, yes?

What you think OutSystems can do about this problem?


Solution

The problem with Richwidgets and London Theme exist for quite some time. I believe the CSS of the Theme warns that not all components will work.


Since the components will work with Lisbon and Liverpool and ofcourse will work with OS11 UI, i don't think they will do anything about it.


If your company is not ready to invest in upgrading to the new OS version, i would recommend to use Liverpool or Lisbon theme for future applications.

Solution

Stefano Valente wrote:

The problem with Richwidgets and London Theme exist for quite some time. I believe the CSS of the Theme warns that not all components will work.


Since the components will work with Lisbon and Liverpool and ofcourse will work with OS11 UI, i don't think they will do anything about it.


If your company is not ready to invest in upgrading to the new OS version, i would recommend to use Liverpool or Lisbon theme for future applications.

Thank you for all the feedback Stefano, 

much appreciated.