Hello guys,

After created a Service Module specifically for SAP connection, when i did deploy from DEV to QA i had this error:


"Error deploying eSpace 'module_SAP' (Deployment failed: Deployment failed. Could not invoke ping. Exception: The remote server returned an error: (404) Not Found.
   at System.Net.HttpWebRequest.GetResponse()
   at OutSystems.HubEdition.ServerCommon.PageInvokes.AbstractInvoker.Invoke(String hostname, String espaceName, String testAreaUser, String documentPath, Action`1 validateResponse) (Espace name: module_SAP, Test area name: , Is running operation: False, Unique ID: , Deploy to separate folder: True, Not using differential Deploy, Previous deployment information wasn't found, Virtual Directory was reused):Internal Error: Deployment failed: Deployment failed. Could not invoke ping. Exception: The remote server returned an error: (404) Not Found.
   at System.Net.HttpWebRequest.GetResponse()
   at OutSystems.HubEdition.ServerCommon.PageInvokes.AbstractInvoker.Invoke(String hostname, String espaceName, String testAreaUser, String documentPath, Action`1 validateResponse) (Espace name: module_SAP, Test area name: , Is running operation: False, Unique ID: , Deploy to separate folder: True, Not using differential Deploy, Previous deployment information wasn't found, Virtual Directory was reused)
System.InvalidOperationException: Deployment failed: Deployment failed. Could not invoke ping. Exception: The remote server returned an error: (404) Not Found.
   at System.Net.HttpWebRequest.GetResponse()
   at OutSystems.HubEdition.ServerCommon.PageInvokes.AbstractInvoker.Invoke(String hostname, String espaceName, String testAreaUser, String documentPath, Action`1 validateResponse) (Espace name: module_SAP, Test area name: , Is running operation: False, Unique ID: , Deploy to separate folder: True, Not using differential Deploy, Previous deployment information wasn't found, Virtual Directory was reused) ---> OutSystems.RuntimeCommon.HEMessageException: Deployment failed: Deployment failed. Could not invoke ping. Exception: The remote server returned an error: (404) Not Found."

"Error finalizing deploy of eSpace 'module_SAP' with unique identifier  (Deployment failed: Deployment failed. Could not invoke ping. Exception: The remote server returned an error: (404) Not Found.
   at System.Net.HttpWebRequest.GetResponse()
   at OutSystems.HubEdition.ServerCommon.PageInvokes.AbstractInvoker.Invoke(String hostname, String espaceName, String testAreaUser, String documentPath, Action`1 validateResponse):Deployment failed: Deployment failed. Could not invoke ping. Exception: The remote server returned an error: (404) Not Found.
   at System.Net.HttpWebRequest.GetResponse()
   at OutSystems.HubEdition.ServerCommon.PageInvokes.AbstractInvoker.Invoke(String hostname, String espaceName, String testAreaUser, String documentPath, Action`1 validateResponse) (Espace name: module_SAP, Test area name: , Is running operation: False, Unique ID: , Deploy to separate folder: True, Not using differential Deploy, Previous deployment information wasn't found, Virtual Directory was reused)) in VMWS5-02IISQA."


On DEV environment i don't have this problem, and on QA the Connection test was successful.

Someone know what could be?


Thankyou.

Agno Silveira wrote:

Hello guys,

After created a Service Module specifically for SAP connection, when i did deploy from DEV to QA i had this error:


"Error deploying eSpace 'module_SAP' (Deployment failed: Deployment failed. Could not invoke ping. Exception: The remote server returned an error: (404) Not Found.
   at System.Net.HttpWebRequest.GetResponse()
   at OutSystems.HubEdition.ServerCommon.PageInvokes.AbstractInvoker.Invoke(String hostname, String espaceName, String testAreaUser, String documentPath, Action`1 validateResponse) (Espace name: module_SAP, Test area name: , Is running operation: False, Unique ID: , Deploy to separate folder: True, Not using differential Deploy, Previous deployment information wasn't found, Virtual Directory was reused):Internal Error: Deployment failed: Deployment failed. Could not invoke ping. Exception: The remote server returned an error: (404) Not Found.
   at System.Net.HttpWebRequest.GetResponse()
   at OutSystems.HubEdition.ServerCommon.PageInvokes.AbstractInvoker.Invoke(String hostname, String espaceName, String testAreaUser, String documentPath, Action`1 validateResponse) (Espace name: module_SAP, Test area name: , Is running operation: False, Unique ID: , Deploy to separate folder: True, Not using differential Deploy, Previous deployment information wasn't found, Virtual Directory was reused)
System.InvalidOperationException: Deployment failed: Deployment failed. Could not invoke ping. Exception: The remote server returned an error: (404) Not Found.
   at System.Net.HttpWebRequest.GetResponse()
   at OutSystems.HubEdition.ServerCommon.PageInvokes.AbstractInvoker.Invoke(String hostname, String espaceName, String testAreaUser, String documentPath, Action`1 validateResponse) (Espace name: module_SAP, Test area name: , Is running operation: False, Unique ID: , Deploy to separate folder: True, Not using differential Deploy, Previous deployment information wasn't found, Virtual Directory was reused) ---> OutSystems.RuntimeCommon.HEMessageException: Deployment failed: Deployment failed. Could not invoke ping. Exception: The remote server returned an error: (404) Not Found."

"Error finalizing deploy of eSpace 'module_SAP' with unique identifier  (Deployment failed: Deployment failed. Could not invoke ping. Exception: The remote server returned an error: (404) Not Found.
   at System.Net.HttpWebRequest.GetResponse()
   at OutSystems.HubEdition.ServerCommon.PageInvokes.AbstractInvoker.Invoke(String hostname, String espaceName, String testAreaUser, String documentPath, Action`1 validateResponse):Deployment failed: Deployment failed. Could not invoke ping. Exception: The remote server returned an error: (404) Not Found.
   at System.Net.HttpWebRequest.GetResponse()
   at OutSystems.HubEdition.ServerCommon.PageInvokes.AbstractInvoker.Invoke(String hostname, String espaceName, String testAreaUser, String documentPath, Action`1 validateResponse) (Espace name: module_SAP, Test area name: , Is running operation: False, Unique ID: , Deploy to separate folder: True, Not using differential Deploy, Previous deployment information wasn't found, Virtual Directory was reused)) in VMWS5-02IISQA."


On DEV environment i don't have this problem, and on QA the Connection test was successful.

Someone know what could be?


Thankyou.


Hello, more informations about error (deploy dev to QA):


after deploy: