I was following the 24h web course building the IMDb-like site, when got stuck where you have to change the CSS. My problem is:

When I change anything in CSS, the page does not change, looks like it is ignoring my instructions!

Gabriel Manzke wrote:

I was following the 24h web course building the IMDb-like site, when got stuck where you have to change the CSS. My problem is:

When I change anything in CSS, the page does not change, looks like it is ignoring my instructions!



Hi Gabriel,

Can you share your module? It will be easier to diagnose if posters can attempt to test it in their own personal area.

Hi Gabriel,


I had same problem, did you by any chance copy-paste CSS from the PDF opened in for example Microsoft Edge ?

There are hidden characters copied along when you do that from certain browsers, which cause the css not being understood.  Try either typing by hand, or copy from other browser (I think Chrome is ok, if I remember correctly, Acrobat Reader should also be OK, I guess)

You should see immediate result inside Service Studio.

Dorine

Afonso Carvalho wrote: Sure, thx for the fast reply

Hi Gabriel,

Can you share your module? It will be easier to diagnose if posters can attempt to test it in their own personal area.



Dorine Boudry wrote: I noticed that so I wrote everything, but still doesn't work

Hi Gabriel,


I had same problem, did you by any chance copy-paste CSS from the PDF opened in for example Microsoft Edge ?

There are hidden characters copied along when you do that from certain browsers, which cause the css not being understood.  Try either typing by hand, or copy from other browser (I think Chrome is ok, if I remember correctly, Acrobat Reader should also be OK, I guess)

You should see immediate result inside Service Studio.

Dorine



Solution

Gabriel Manzke wrote:

Dorine Boudry wrote: I noticed that so I wrote everything, but still doesn't work

Hi Gabriel,


I had same problem, did you by any chance copy-paste CSS from the PDF opened in for example Microsoft Edge ?

There are hidden characters copied along when you do that from certain browsers, which cause the css not being understood.  Try either typing by hand, or copy from other browser (I think Chrome is ok, if I remember correctly, Acrobat Reader should also be OK, I guess)

You should see immediate result inside Service Studio.

Dorine



here's your problem, should be double quote :

 


Solution

When you copy paste from PDF sometimes the ' character is not correctly pasted. You have to correct them manually. They are curly if wrong.

Another thing you can do is delete browser cache, or in chrome debugger switch of caching.

I always prefer to have browser caching off when working on CSS.

Dorine Boudry wrote:

Gabriel Manzke wrote:

Dorine Boudry wrote: I noticed that so I wrote everything, but still doesn't work

Hi Gabriel,


I had same problem, did you by any chance copy-paste CSS from the PDF opened in for example Microsoft Edge ?

There are hidden characters copied along when you do that from certain browsers, which cause the css not being understood.  Try either typing by hand, or copy from other browser (I think Chrome is ok, if I remember correctly, Acrobat Reader should also be OK, I guess)

You should see immediate result inside Service Studio.

Dorine



here's your problem, should be double quote :

 



Wow, feel so stupid right now, big thanks!!!

Gabriel Manzke wrote:

Dorine Boudry wrote:

Gabriel Manzke wrote:

Dorine Boudry wrote: I noticed that so I wrote everything, but still doesn't work

Hi Gabriel,


I had same problem, did you by any chance copy-paste CSS from the PDF opened in for example Microsoft Edge ?

There are hidden characters copied along when you do that from certain browsers, which cause the css not being understood.  Try either typing by hand, or copy from other browser (I think Chrome is ok, if I remember correctly, Acrobat Reader should also be OK, I guess)

You should see immediate result inside Service Studio.

Dorine



here's your problem, should be double quote :

 



Wow, feel so stupid right now, big thanks!!!


Hi Gabriel,

Glad that you found a working solution from Dorine in our OutSystems community.

Enjoy learning and don't be afraid to make new mistakes! It will probably stick to memory better.  :-)

We're all here to learn and help. Cheers!

Boney