Issue in emails sending to BCC recipient.
Question

Hi,

I am sending email to BCC but the BCC recipient could not receive the email. 

1. Hardcoded in BCC with the email address.

2. Created a Site variable of email type for email recepients and passed the variable in BCC.


Can some one please help me on this.


Thanks.

Saicharan

mvp_badge
MVP

Hi Saicharan,

"the BCC recipient could not receive the email" could have all kinds of causes, most of which aren't an OutSystem problem. Did you try that same address as CC? And did that work?

Kilian Hekhuis wrote:

Hi Saicharan,

"the BCC recipient could not receive the email" could have all kinds of causes, most of which aren't an OutSystem problem. Did you try that same address as CC? And did that work?

Hi Kilian,

Yes, CC is working fine. Is there any configuration that needs to be enabled to send emails to BCC?


Thanks,

Saicharan


mvp_badge
MVP

The Platform just passes the BCC and other data to the mail server. There might be some configuration there, although I would find it odd. In any case, I don't think this is an OutSystems problem.

There's at least one thing you can do to check whether the BCC is recognized by the Platform: check the Email Log in Service Center (Monitoring/Emails). It shows To/From/CC/BCC, if I'm not mistaken. Alternatively, you could query the Email System Entity: it contains both the CC and BCC Attributes.

Kilian Hekhuis wrote:

The Platform just passes the BCC and other data to the mail server. There might be some configuration there, although I would find it odd. In any case, I don't think this is an OutSystems problem.

There's at least one thing you can do to check whether the BCC is recognized by the Platform: check the Email Log in Service Center (Monitoring/Emails). It shows To/From/CC/BCC, if I'm not mistaken. Alternatively, you could query the Email System Entity: it contains both the CC and BCC Attributes.


Hi,

Email log shows only to and cc. But bcc isn't shown. 

Thanks,

Saicharan

mvp_badge
MVP

If you specified a BCC, the BCC is visible in Service Center:

So if Service Center does't show a BCC, you didn't provide one. Please debug your code to see if there's really a BCC address, and whether that's really different from both the "To" and "CC" addresses.

I realize that this is a bit old - but incase anybody else stumbles across this - thought I'd share...

If you are redirecting emails in Service Center for a platform, you will NOT see the BCCs in the email logs. 


You will only see the recipients show in the logs if the emails are able to send through (and all of the sage advise that everyone else provided already was followed).

I spent a bit of time chasing this one down with an exchange server - only to realize this.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.