editable table sending null record even if table is empty

Hi,

I have used an editable table and save button. If I click on save then my records will be updated in entity. If I have not entered any value and click on save, then the list coming from editable table should be empty but it is sending null values and list is not empty. Can anyone please help me with this.

Smriti

Hi Smriti,


Can you provide some pictures or sample oml because it helps to more understand.


Thanks

If you haven't entered any values, what did you expect to see?


As far as i can tell you need to do the validation in your on save screen action.

Stefano Valente wrote:

If you haven't entered any values, what did you expect to see?


As far as i can tell you need to do the validation in your on save screen action.

Hi,

I have done the validation to check if it is empty. It is passing the validation 

Then have you made the fields mandatory?

If you dont want to store empty records, you have to make the inputs of the attributes mandatory in order to get the validation.

Stefano Valente wrote:

Then have you made the fields mandatory?

If you dont want to store empty records, you have to make the inputs of the attributes mandatory in order to get the validation.


yes i have made the field mandatory as well

Your on save should look like this:


To get this result:

Stefano Valente wrote:

Your on save should look like this:


To get this result:

I have done this in my application


And did it solve your problem?

Stefano Valente wrote:

And did it solve your problem?

I had done it before I posted my problem.

Can you send your oml?

If you already implemented this but you still get empty records something strange is going on.