[Data Grid] Data Grid Grouping not working with Google Chrome but does with FireFox or IE?

Forge Component
(28)
Published on 24 Sep (3 weeks ago) by OutSystems R&D
28 votes
Published on 24 Sep (3 weeks ago) by OutSystems R&D

I have some Data Grids in my Application, the grouping function does not work with Google Chrome, however; it does with FireFox or IE?

Hi Regina,

What do mean by not working? I checked the following pages with chrome and looks like its working.

https://outsystemsui.outsystems.com/DataGridSample/Grid.aspx

https://outsystemsui.outsystems.com/DataGridSample/ExpandableGroups.aspx

You can get the solution of those pages here.

Regards,

Marcelo

Marcelo Ferreira wrote:

Hi Regina,

What do mean by not working? I checked the following pages with chrome and looks like its working.

https://outsystemsui.outsystems.com/DataGridSample/Grid.aspx

https://outsystemsui.outsystems.com/DataGridSample/ExpandableGroups.aspx

You can get the solution of those pages here.

Regards,

Marcelo

Yes those links work for me.   When I have a grid in my application environment it ONLY works with FireFox or IE and not Google Chrome?


Hi Regina,

Do you have the latest version of Data Grid? Did you download the example to make sure you are doing it the same way as those pages?

Regards,

Marcelo

Marcelo Ferreira wrote:

Hi Regina,

Do you have the latest version of Data Grid? Did you download the example to make sure you are doing it the same way as those pages?

Regards,

Marcelo

I would have to do a screen share to show you what is happening but yes I have the latest grid and working on others so confused why not IE.


Can you share a small sample OML that reproduces the issue you're seeing?

Or share a URL to a public-facing example?

Barring an OML, it would be helpful to have steps to reproduce the issue. For example, are you just using a grid container with autogenerate columns? Or are you using specific column types? 

I would also recommend using the Chrome browser tools to check the console for JS errors, which might at least help with troubleshooting.

Perhaps there's something specific to your data that is causing issues with grouping.