Error using RichWidgets/Input_Autocomplete

Error using RichWidgets/Input_Autocomplete

  
Hello,

I'm trying to use the autocomplete widget but keep getting these javascript execution errors:

Error: $.widget is not a function
Source File: /Blocks/RichWidgets/RichWidgets/Input_Autocomplete.pt.js
Line: 430

Error: $("#" + inputId).autocomplete is not a function
Source File: /Blocks/RichWidgets/RichWidgets/Input_Autocomplete.pt.js
Line: 871

I suspect this may have something to do with the order by which the js assets are included. The JQuery Core appears after the Input_Autocomplete.pt.js in the generated HTML (HTML snippet included in attached file).

Any idea how to fix or work around this problem?

Thanks,

Paulo
Hi Paulo,

What version of the OutSystems Platform are you using?
If you use the latest versions of the OutSystems Platform and of the Style Guide that problem should not appear anymore.

Cheers,
Tiago Simões
Hi Tiago,

I was using version 4.2.4.9 of the platform.

After upgrading to 4.2.4.15 and using the latest StyleGuide (Feb 17) the problem was fixed.

Thanks.

Paulo