469
Views
14
Comments
Reactive Web App not working

I have created a web app using the new Reactive Web App templates. However once I moved back to my development machine at work I was getting the following error.


Unavailable Feature
The environment you're logged into doesn't support Reactive Web - Aggregate Start Index. Upgrade the environment to publish the module.


The service studio versions and platform server versions are the same as the other machine and there is no difference. My only thought would be something with the port blocking or corporate proxy that would be affecting this.

What sort of network connectivity is required from the development environment in order to create/deploy the new Reactive Web Apps?

Service Studio Version - 11.6.1

mvp_badge
MVP
Rank: #18

Hi,

You have to update some forge components related to OutSystems UI too, maybe that is not done yet done in the environment that you get the error ?

Read the FAQ section of https://outsystemsui.outsystems.com/OutSystemsUIWebsite/WhatsNew

For instructions.

Regards,

Daniel

Rank: #39594

Hi Daniel,

Thanks for the swift reply. I don't think this is related to components as it runs fine on another machine. I have tried re-installing service studio on the error'ing machine as well.

Thanks,

Tom

mvp_badge
MVP
Rank: #18

Can you show a screen print of service center on the right the platform server version is shown.

Rank: #39594

Hi Daniel,

Is this what you are looking for...

mvp_badge
MVP
Rank: #18

Yes, that is indeed the correct version number.

So if version number of environment is correct and you have followed instructions as outlined in the FAQ I referred to, then I do not understand why you get these error messages.

Are you sure it is the same environment? 

Could it be on one machine you are in the development environment and in the other for example logged into that test environment?

Rank: #39594

Now you know why I have been scratching my head as well. Is there some calls that are made from Service Studio back to Outsystems central servers as part of development? Similar to how the templates are used? I might need to configure some proxy whitelisting to resolve this.

mvp_badge
MVP
Rank: #18

That part I don't know about unfortunately.

Maybe one of the OutSystems MVPs could check this with OutSytems? Why they read this.

mvp_badge
MVP
Rank: #18

One more thing I see there is a Oct 2019 CP1 of the platform server available. Check out the rekease notes. Maybe it is related.

https://www.outsystems.com/downloads/ScreenDetails.aspx?MajorVersion=11&ReleaseId=19355&ComponentName=Platform+Server

Rank: #1355

Hey Tom!

Yeah, i've got the same issue in my personal environment.  You have to go to the forge and download Outsystems UI 2.2.5, upload and install it.  Then i went back to forge and updated Outsystems UI Web Screen Templates.  Not 100% sure if this last step is necessary but it worked for me.

Rank: #3691

I am getting similar errors:


Appreciate your support.



Unavailable Feature
The environment you're logged into doesn't support 'Options Content Property for Dropdown in Mobile and Reactive modules'. Upgrade the environment to publish the module.

Unavailable Feature
The environment you're logged into doesn't support 'Is Form Default Property for Buttons in Mobile and Reactive modules'. Upgrade the environment to publish the module.

mvp_badge
MVP
Rank: #18

Hi Maitha,

Did you try the steps that Steve describes? Did it not solve your problem?

Regards,

Daniel

Rank: #39594

It is related to my internal firewall and some issues between that and the platform server. If I attempt to open the application on a different network then it works fine.

Rank: #51503

Hello!

I've just faced with the same issue for radio button group (The environment you're logged into doesn't support 'Radio Button Widget'. Upgrade the environment to publish the module.).
Server version is 11.7.3
Outsytems UI has been just updated from Forge by latest version
Visual Studio version is 11.7.15

Valery