Error Publishing in node localhost

Error Publishing in node localhost

  
Can anyone help me on this error that i get at the end of the deployment phase?

Error publishing in node localhost (127.0.0.1): Internal Error
The path specified cannot be used at this time. (Exception from HRESULT: 0x80070094)
System.Runtime.InteropServices.COMException (0x80070094): The path specified cannot be used at this time. (Exception from HRESULT: 0x80070094)
at System.DirectoryServices.DirectoryEntry.CommitChanges()
at OutSystems.HubEdition.DeployService.Deploy.#c.#sf.#7f(String eSpaceName, String ptaName)
at OutSystems.HubEdition.DeployService.Deploy.#c.#sf.#Gf(String espaceName, String testAreaName, Boolean partial)
at OutSystems.HubEdition.DeployService.Deploy.#Gf(String espaceName, String userName, Boolean partial, Boolean forceRedeploy, Boolean alreadyLocked)
CompModule : Broadcast Message
Thanks,
RP
Hi Rui

This error occurs due to a concurrent thread access to the IIS 6 or 7 metabase, and is known to be an IIS bug as identified by Microsoft article http://support.microsoft.com/kb/946517.

In this same article you'll find a publicly available hotfix for IIS that addresses this problem. Please download and install the version correspondent to your operating system and architecture.

Until you apply the hotfix, you can workaround this error by restarting the OutSystems Deployment Service and IIS. If the problem persists, stop the Scheduler service, and then restart Deployment Service and IIS one at the time.

Let us know your findings.

Cheers

Miguel
I am getting this exact same error message on a Windows Server 2008R2 system running IIS7.

The hotfix does not apply to 2008R2.


Google is drawing a blank and this is the only OutSystems forum post that references 0x80070094.


As it turns out the error code was NOT 0x80070094 (not directly anyway)
iisreset would stop the service but and not start it back up and caused: 0x80071A91 for the WAS (W3svc)

Installing this hotfix - but won't really know if it fixes it for me unless it happens again (Or rather doesn't, hopefully).

https://support.microsoft.com/en-us/kb/975443 for WindowsServer 2008 R2
Hello,

Thanks for sharing. Keep us appraised if the problem happens again.

Cheers