Hello,

I have created a new application with a Web Responsive module. In this module, I simply created an Empty webpage and tried to open it on the browser. 


That's all I did, but in the browser it shows a message saying "There was an error processing your request." and a link to RELOAD.

In service studio, the error is the following:

HTTPS connection required.
   at OutSystems.RESTService.Controllers.RestServiceApiController.ValidateRequestSecurity()
   at OutSystems.RESTService.Controllers.ModuleServicesApiController.Ping()

Since the only thing I did was creating an empty page, wonder what is the problem here.


Thank you,

João Lopes

Hi João,

Reactive web apps require https. Make sure the url you are using in the browser starts with "https://" (and that your server has a valid SSL certificate).

Cheers,
Tiago Simões

I have the https://. My URL is https://joao-p-de-lopes.outsystemscloud.com/(...) and I think the image below shows that my server SSL certificate is valid, right?

Hi João,

You are right, personal environments are already correctly set up. Can you share the module you are working on (or a subset of it) and/or the URL to the screen that shows the error you are mentioning?

Cheers,
Tiago Simões

Tiago Simões wrote:

Hi João,

You are right, personal environments are already correctly set up. Can you share the module you are working on (or a subset of it) and/or the URL to the screen that shows the error you are mentioning?

Cheers,
Tiago Simões

Hi, 

Today it was already working, and I did not do any changes.

My environment was previously asleep, so maybe there was an error waking it up. No clue.


Anyway, 

Thank you for your help


It happens from time to time. I have encountered this myself and for my team. Encountered issues logging in to the Server within Service Studio.

"Server was unable to process request. ---> HTTPS connection required for this web service."

Try restoring the Service Studio to its default setting and give it a go.

Jose Roberto Littaua wrote:

It happens from time to time. I have encountered this myself and for my team. Encountered issues logging in to the Server within Service Studio.

"Server was unable to process request. ---> HTTPS connection required for this web service."

Try restoring the Service Studio to its default setting and give it a go.

Thanks, Jose Roberto Littaua,

It works like a charm.

I tried multiple solutions & even Re-Install.
But Restoring helped me to fix the same.