Application doesn't start (timeout)

Application doesn't start (timeout)


I am working on an application that was developed by another company. The application was developed in Outsystems 4.0 and migrated to 4.1 a few months ago. I don't know if the application ever worked after the migration, but right now the application is not working. When I try to launch the application, either from service center, or from the "Run" within service studio, or directly on the browser, the page load takes forever and nothing shows up. Eventually, the monitoring reports a timeout. I tried changing the request timeout in machine.config, but it still does nothing.

The database server is reachable from the hub server and if I test the connection from Hub Server Configuration it reports a successful connection.

I then started suspecting the Integrated Windows Authentication, so I removed temporarily all the code relative to authentication... and the application got loaded in the browser.

The strangest thing is that I tried to debug the application, to see where it could be failing, and the debugger didn't stop in any place.

I have an entry point (default) that points to a "Login" screen. The screen has the 'Integrated Authentication' property set to Yes and is a frequent destination. It also has Permissions set to three types of users: Anonymous, Registered and Admin. User types are all checked, so I suppose that any anonymous user could go in. That Login screen doesn't have a login form, so the user can only continue it its credentials are valid. Thus, the first action in the login's preparation is IntegratedSecurityGetDetails.

This could be the problem right here if my user didn't have permissions. However, wasn't the debugger supposed to reach at least the entry point, or the "Start" icon in the preparation action (I placed a breakpoint in both icons)?

Is there something I'm missing? Wasn't the debugger supposed to stop on the breakpoints placed on the "first instruction"? If the database server is reachable, where can the timeout come from if the application doesn't even get inside the code?

Thank you for any help you can give me.
Just to give you some more analisys data...

The application throws this request timeout error, visible in Service Center monitoring as:
Request timed out.
Current Url: /xxx/default.aspx
Application Path: C:\Program Files\OutSystems\Service Center\running\xxx\
Process Id: 20604
Thread Id: 17

The htpRuntime tag in the machine.config has an executionTimeout property set to 600s.