Error on using extension : " Exception: Retrieving the COM class factory for com

Error on using extension : " Exception: Retrieving the COM class factory for com

  
Hi, I've made an extension and it works ok if I test it using a windows form (in the same project).
I've published and tried inside an Outsystems application, as an action, and I get the error

" Exception: Retrieving the COM class factory for component with CLSID {000209FF-0000-0000-C000-000000000046} failed due to the following error: 80070005."

Is this something known?

Find attached the extension.
Maybe there's something regarding to users...
Hi Carolina,

You are most likely right!

This error typically shows up when you are accessing a COM service which requires permissions higher than those given by default to IIS processes.

The easy way to go around this is to create a user in your server with the required permissions and then use the "Run As" functionality found in Service Center.
An alternative is to place the espaces that use this extension in a different IIS Application Pool and defining its permissions explicitly.

Hope this helps,
Pedro Oliveira
Hi!!
Thank you for you answer.
This user must be local or in network? Do I need to create it with the permissions of the IIS user plus the permission in tem folder?
Sorry about this question but I'm notthat familiar with those things regarding to server and users.
Thank you
Typically this needs to be a user that can login in the server.

It can be either local to the machine or be provided by Active Directory.

The actual permissions required depend what exactly you COM component is doing. The way I would approach it would be to start by providing the user with Administrator privileges to make sure what you facing is a indeed a permissions issue. And would then gradually cut down the permissions given.

Pedro
Thank you! I've created a new user and at least I don't get the previous error... now it's:

ExpMsg: Windows cannot print due to a problem with the current printer setup. Try one or more of the following: * Check the printer by printing a test page from Windows. * Make sure the printer is turned on and online. * Reinstall the printer driver.

I've done what the message says and everything is ok with the printer. I'll keep on trying.
I'll come back.

Thank you!
This is all about configuration. There was no printer for the user I've created! :D
Everything works now
Thank you.
Great!

Glad to hear you've managed to get everything to work properly!

Good work ;-)

All the best,
Pedro Oliveira