403 forbidden http instead of https between UI and Service Module?

Hi,

We have on premise deployment in our company.

A service module and an web module have been setup so that the web calls the services from service module. There are always 403 errors. 

Postman was used to test services and they work correctly with https.

For some reason, the calls issued from UI module are always http.  Attached please see the details of the logs grabbed from within Service Center.

We are paid customer. Please help.

Burt

Error Detail

Back to Log

Id:

d9dca797-c0b6-440b-a6fc-581fcaad1eb3

Time of Log:

2019-11-07 09:45:48

Request Key:2a195881-821a-4970-b383-f4870dc7016e

Module:

TestServiceAction_UI

Tenant:

Users

User:

Session Id:

GrRSZwpH9ki0+SZqSzvCNw==

Server:

xxxx

Module:

Message:

The remote server returned an error: (403) Forbidden.

Environment InformationeSpaceVer: Id=2979, PubId=0, CompiledWith=11.0.607.0

RequestUrl: https://xxx.xxx.ca/TestServiceAction_UI/TestTwoX.aspx (Method: POST)

AppDomain: /LM/W3SVC/1/ROOT/TestServiceAction_UI-533-132176146187532010

FilePath: E:\Outsystems\running\TestServiceAction_UI.01109485755\TestTwoX.aspx

ClientIp: 10.22.10.31

Locale: en-US

DateFormat: yyyy-MM-dd

PID: 3816 ('w3wp', Started='2019-10-31 10:30:48 PM', Priv=1148Mb, Virt=2116076Mb)

TID: 12

Thread Name:

.NET: 4.0.30319.42000

Stack:

The remote server returned an error: (403) Forbidden.

   at ssTestServiceAction_UI.RsseSpaceTestServiceAction.TestServiceActionServiceAPIClients.TwoXServiceAction(HeContext heContext, Nullable`1 inParamInput, Int32& outParamOutput)

   at ssTestServiceAction_UI.RsseSpaceTestServiceAction.TwoXServiceAction(HeContext heContext, Nullable`1 inParamInput, Int32& outParamOutput)

   at ssTestServiceAction_UI.Flows.FlowMainFlow.ScrnTestTwoX.CommandCallTwoX(HeContext heContext)