Hello, I only want to show calendar widget without input. How can i do that?


Hi Phone, i did some work around,

on the input extended properties add style = "display:none;"

the input will not be visible but the calendar widget will work


regards,

Marvei

note!, visible = false on input properties will not work, tried that already

Marvei Nii~ wrote:

note!, visible = false on input properties will not work, tried that already

What type of widget should i use. Date Picker or Input Calendar? Thanks.


Please see this oml, hope this helps 


Cheers!

Phone wrote:

Marvei Nii~ wrote:

note!, visible = false on input properties will not work, tried that already

What type of widget should i use. Date Picker or Input Calendar? Thanks.


use the Datepicker widget


Marvei Nii~ wrote:

Phone wrote:

Marvei Nii~ wrote:

note!, visible = false on input properties will not work, tried that already

What type of widget should i use. Date Picker or Input Calendar? Thanks.


use the Datepicker widget



Hey Marvei, I did the same things as you mention. But not working. I think something wrong, both input box and date picker disappear when i set style property " display:none" in extended property. Here are the screenshots.

add semi colon after none, 

"display: none;"

Marvei Nii~ wrote:

add semi colon after none, 

"display: none;"


Uhhh, nothing different, still not appearing. By the way, i am using outsystems 11. Is that relevant?

you need  to add a button, on the datepicker widget, add the button id on the buttonwidgetid of the datepicker widget,


try opening my attached .oml 

Hi, Phone

The datepicker widget has replaced the Calendar in OS11. Also it does not need to be associated to a buttonId, as it doesn't need the buttonwidgetId input. As such, you should be able to use it without associating it to an input. To control it's visiblity through a button or link is a matter of creating a screen action that changes a boolean variable that controls the Visible parameter of the container with the datepicker widget.

Let me know if this helps,

Sam