Upgrading from 4.0 to platform 4.2 - Licensing Error

Upgrading from 4.0 to platform 4.2 - Licensing Error


I recently upgrade my outsystems platform from version 4.0 to version

Everything is working fine but sometimes i get an Licensing Error in Error Log screen.

The reported error message is:
Licensing Error: Data at the root level is invalid. Line 1, position 1.

The error detail is:

Time of Log:07-07-2009 13:13:12

eSpace Name:

Tenant Name:

User Id:0

Session Id:

Module Name:Licensing

Message:Licensing Error: Data at the root level is invalid. Line 1, position 1.

Stack:Data at the root level is invalid. Line 1, position 1.
at System.Xml.XmlTextReaderImpl.Throw(Exception e)
at System.Xml.XmlTextReaderImpl.Throw(String res, String arg)
at System.Xml.XmlTextReaderImpl.ParseRootLevelWhitespace()
at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
at System.Xml.XmlTextReaderImpl.Read()
at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
at System.Xml.XmlDocument.Load(XmlReader reader)
at System.Xml.XmlDocument.Load(TextReader txtReader)
at OutSystems.HubEdition.Common.Utils.OmlUtils.#T(Byte[] buf, String type)
at OutSystems.HubEdition.Common.Utils.OmlUtils.GetEspaceInfoFromOML(Byte[] OML, String& name, String& UID, Boolean& isSystem, Boolean& isMultitenant, String& versionHistory, Boolean& isValid, Boolean& userEntity, String& serviceStudioVersion, String& lastUpgradeVersion, String& description, String& hash, DateTime& lastModified, Boolean& isUserProvider, String& userP...Authentication, Boolean& hasMobileWeb, Boolean& hasSMS, Boolean& hasWebServices, String& activationCode)
at OutSystems.Activation.Logic.Validations.ValidationWap.GetFeatureUsageFromOml(Byte[] oml)
at OutSystems.Activation.Logic.Validations.AbstractVersionedEspaceValidation.GetFeatureUsageFromObject(ObjectVersion version)
at OutSystems.Activation.Logic.Validations.AbstractVersionedObjectValidation.RefreshObjectFeatureUsage(ObjectVersion version, ThreadSoftAbort softAbort)
at OutSystems.Activation.Logic.Validations.AbstractVersionedObjectValidation.RefreshObjectFeatureUsage(IRefreshableObject o, ThreadSoftAbort softAbort)
at OutSystems.Activation.Logic.Validations.AbstractHeavyWeightValidation.#c.#Wab.#bbb()
eSpaceVer: 0 (Id=0, PubId=0, CompiledWith=
AppDomain: CompilerService.exe
Path: C:\...\HS\
PID: 3572 ('CompilerService', Started='29-06-2009 14:00:35', Priv=80Mb, Virt=201Mb)
TID: 20
.NET: 2.0.50727.42

Before i upgrade the plataform i create a backup from the License and after the upgrade i upload the License but it stills give me this error sometimes.

Does anyone knows how can i resolve this error?

Thanks in advance,

Gonçalo Marques

Maybe your iis, is configured to run .NET version 1.1 instead of version 2.0 or the framework 2 is not installed. Outsystems 4.0 is for framework 1 (visual studio 2003) and the version 4.2 is for framework 2(visual studio 2005). Probably that's the problem or one of them.

Nelson Inácio

Thanks for your answer,

That was the problem, my iis was configured to run .NET version 1.1 insted of version 2.0.

Thanks a lot for your answer,

Gonçalo Marques