how to make the debugger works for API producer module

I am working on a client project using Outsystem 10 with on-premise infrastructure using MSSQL Server 2016.

There are two applications created, one for Web (Producer) and one for Mobile (Consumer).


(1) Web Application

- XXX_Core

----- Entities (exposed read-only true)

- YYY_API

----- Server Action to access the data in the entities.

- ZZZ (Responsive UI layer)


(2) Mobile Application

- Mobile layer where it consumes the exposed API in the web application.


This is what i tried to get the debugger to break on the Producer module and it worked for 4 days but somehow it failed to work since yesterday.

In XXX_Core module, I set the debugger entry module to be at YYY_API module. Both module contains breakpoints too.

Then i start the debugger from XXX_Core module. 


Finally i also started the debugger from the Mobile App layer too. 

I do not have any break point in the Mobile App layer.

When i clicked a certain button in the mobile layer, it breaks well at the XXX_Core module.

This worked for 4 days.


But it stopped breaking yesterday.


How can I rectify this issue? What is the correct way to do this if my approach is incorrect?


I have checked various link including this one, but it does not work for me https://success.outsystems.com/Documentation/11/Developing_an_Application/Troubleshooting_Applications/Debugging_Applications/Debugging_Producer_Modules#pre-requisites

Hi,

I never went through the same, probably some changes have been made in the meantime.

But if it worked for 4 days what I suggest is that you refresh the references of the web modules and then publish. And after do the same with the mobile app.

Hope it helps :)

Hi Newbie,

The only reason I can think of that it stopped working is that someone (if not you) published a new version of YYY_API or XXX_Core, though I'm not 100% sure this can cause the behaviour you experience.

Thank you to both Nelio and Kilian for your response.

i monitored the situation for a few days and i think Kilian suspicious is the closest.