[Factory Configuration] Unable to access url 'http://localhost/ServiceCenter/Operation.asmx?wsdl'

Forge Component
(22)
Published on 11 Nov (3 weeks ago) by OutSystems R&D
22 votes
Published on 11 Nov (3 weeks ago) by OutSystems R&D

Hi there,

When publishing 11.0.2 in platform 11.0.212.0 I get the following message:

Consumed SOAP Web Service Integrity

Unable to access url 'http://localhost/ServiceCenter/Operation.asmx?wsdl' to verify if 'Operation' consumed SOAP web service is up-to-date.

Couldn't access resource at http://localhost/ServiceCenter/Operation.asmx?wsdl

When logging in a 404 is thrown, I presume because the webservice doesn't work well.

How can I solve this?

Thanks,

Wilko

Solution

I just worked around this today by setting an effective URL for this web service using the Integrations tab in service center


If you're not familiar with Service Center, do the following:

1) Navigate to Service Center (https://{your server or personal env URL}/servicecenter)

2) Log in with your Service Center or Personal Environment credentials

3) Click the following in sequence 

  • Factory (Main Top Menu)
  • Applications (Secondary Top Menu)
  • Factory Configuration (List Option under "Applications" list) 
  • FactoryConfiguration (List Option under "Modules" list)
  • Integrations (Tab)
  • Operation (List Option under the "Consumed SOAP Web Services" section)

4) Set the effective URL to https://{your server or personal env URL}/servicecenter/Operation.asmx


Hope this helps!

Ross

Solution

Ross hi,

I changed the URL in the operations tab, republished it and it gave some errors. I went back to service studio, refreshed the linked and published there with success.

Thanks for the help.

Wilko