Hi All,

I've been having some issues when trying to use "date picker", basically i´m having the same problem reported in this thread: https://www.outsystems.com/forums/discussion/54056/datepicker-doesnt-set-selected-value/, but for some reason i can´t solve it...

I'm trying to filter expenses from a date interval, so i choose the start and end date, and if it was working as expected, the table should return the expenses between the choosen dates. When seleting the start date it works, but when i choose the end date, no value is returned.


At the moment this is how i it have configured:

The aggregate filter : 

Data type for both variables is "date".


We have start date and end date for selection 

For the start date button:

For the date picker start date:

For the end date button:

And for the date picker end date:


The actions are similar for both:


Thanks in advance.

Hi tozas1979,

                    I have used this SQL query to filter the data from start date and end date,  And its working fine.




In this scenario, Instead of using 2 different screen action for button,  you can give our SQL snippet  in single screen action and map that screen action for two buttons (Try this SQL snippet in that start and end date button Screen/Client action.).


SyntaxEditor Code Snippet

Select {EntityName}.[Attribute] 
from {Attribute} 
WHERE {EntityName}.[Attribute] BETWEEN @StartDate AND @EndDate


Regards,

Gnanavel Sivasankaran.

Hi tozas1979,

Try with following date filters condition,

Add this filters one by one.

1) For Start Date,

DashboardFilters.StartDate=NullDate()
or DashboardFilters.StartDate <= Entity.CreatedOn

2) For End Date,

SyntaxEditor Code Snippet

DashboardFilters.EndDate=NullDate()
or DashboardFilters.EndDate >= Entity.CreatedOn

tozas1979 wrote:

Hi All,

I've been having some issues when trying to use "date picker", basically i´m having the same problem reported in this thread: https://www.outsystems.com/forums/discussion/54056/datepicker-doesnt-set-selected-value/, but for some reason i can´t solve it...

I'm trying to filter expenses from a date interval, so i choose the start and end date, and if it was working as expected, the table should return the expenses between the choosen dates. When seleting the start date it works, but when i choose the end date, no value is returned.


At the moment this is how i it have configured:

The aggregate filter : 

Data type for both variables is "date".


We have start date and end date for selection 

For the start date button:

For the date picker start date:

For the end date button:

And for the date picker end date:


The actions are similar for both:


Thanks in advance.

Hi tozas1979,

Please ensure the variable you have used is of same datatype. 

If any of the variable datatype is datetime then you need to use datetimetodate() function

Regard,

Ellakkiya.s



Hi all,

I've tried all the sugestions with no success, then i tried the one mencioned in my opening post and for some reason i can't explain it started working...

Thank you for all you inputs and help.

Regards.